Can't connect to Roon on Orbi/Xfinity network

Core Machine (Operating system/System info/Roon build number)

Roon is running on SmallGreen Computer sonicTransporter
Linux machine, but I don’t have access to give you which one and build number
Roon version 1.7 (build 555)

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Xfinity cable modem/router (ARRIS Group modem TG3482G)
Ethernet connections from sonicTransporter to Orbi and from Orbi to Xfinity
Orbi38 set up as access point (bridged) - RBR50

I’ve tried connecting with my Dell laptop, a Dell desktop and my iPhone. Same result from all. Even back when I had intermittent success, always got the same result from all 3 devices.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Not hooked up yet.

Description Of Issue

A bit of history here. I bought the sonicTransporter a few years ago and have spent quite a while loading 11,000+ albums onto the disk. I was listening on different system.

About a half year ago, we moved to another location and I tried to get Roon running on my laptop. Success was what you’d call “spotty” I suppose. Roon would show up suddenly and stay up for a few days and then disappear. Could do nothing to get it running again. Then, 2 or 3 weeks later it would mysteriously pop up again and run for another few days. Not happy about that, but as we were moving once again in a few months didn’t want to go through the trouble of figuring out the issue on this network only to run into something else after moving.

Now in my final (I hope) location, I have been unable to get Roon to run at all. I’ve looked at the Orbi and Xfinity settings and don’t see anything problematic like I’ve read in other posts.

Hello @Stephen_Brill,

Can you please confirm the Orbi and the Arris are on the latest firmware?

Since you are using an Orbi router/access point, I would also check to see if you have enabled the settings we suggest on our Networking Best Practices Guide:

Netgear Orbi Routers

If you’re making use of an Orbi router, we recommend unchecking Disable IGMP Proxying in your router’s settings. This setting can interfere with the ability for Roon Remotes to connect to the Roon Core.

Hi Noris,

As I’ve bridged the Orbi (“AP” mode), it is acting as a switch and not router, and so I don’t even see that router setting. I did just update the firmware from to

The Xfinity router doesn’t show any setting like that, and I can’t see anywhere from the admin panel where to update firmware. Probably have to talk to spectrum for that.

The Orbi rebooted almost an hour now and I restarted the sonicTransporter (henceforth “ST”), and still no connect to core.

I should add that I am able to connect to the ST box OK, and use the apps there to import CDs and can connect to the filesystem use Windows Explorer to add FLAC files and whatnot. The Sqeezebox app seems to run fine. No Roon, though :frowning:

Hi @Stephen_Brill,

Are you able to set the Orbi to “router” mode on your end and place the Xfinity into Bridge Mode? In the past we have seen multicast issues surrounding ISP-provided networking gear, and I’m wondering if this is perhaps what’s going on your end as well.

Thought you might suggest something horrible like that. With wife and two twenty-something daughters I take my life in my hands messing with internet. The Orbi firmware upgrade alone had them lookng for blood. You bet I didn’t own up to that. I’ll give it a shot around 2:00 AM when household reaches quiescence, and report back tomorrow. Thanks!


Sorry to suggest something as “horrible” as re-configuring the network :slight_smile:

Sounds like a plan, do let me know how it goes!

Tried this early to make sure support folks were still around. As expected, it went horribly. Reconfigured Orbi as router (fine!) and then set Xfinity router/modem in bridge mode, upon which the Xfinity reset and never came back. Call to Comcast to get it back to factory settings and put everything back the way it was due to angry mob standing around with pitchforks. Next attempt will not be until the weekend.

1 Like

Hi @Stephen_Brill,

Sorry to hear the network modifications are going less than ideal. Sometimes you need to reset both the router + modem after making changes, but I would double check proper steps with Comcast if the Xfinity is having issues booting.

Time for the update, Noris. Good news and bad news.

I was able to set up the Xfinity cable modem/router in bridge mode so that the Orbi is the router in the network. Booted everything up last weekend (the 21st) and Roon came back! It’s been working well all week, but today Roon once again disappeared. Cannot connect to it on my work laptop (at home), iPhone, or home PC. All those endpoints had been working.

This is the same problem I’ve had in the past, where Roon would show up for 4 or 5 days and then be unresponsive for weeks or months. Please tell me there’s something else to try!

I’d contact small green and ask them for some help as that sounds really odd. They are very good with their support and it is a custom device.

OK, have sent in ticket for Smally Green to troubleshoot

Got the bad news from Small Green. My SonicTransporter, which I purchased in 2016 with sufficient disk to store 200K tracks for $1400, won’t run Roon with more than 5K tracks. I’ve got roughly 160K now.

Roon now requires more processor than that box has, and I need to spend another $900 to get a new driveless SonicTransporter and hook up my old one to as NAS. Quite unhappy about this. I can see needing to spend $1K or whatever every few years to keep Roon running.

Why don’t you ditch the SonicTransporter and build a NUC that will run Roon sufficiently well for less that that and leave you with the flexibility to upgrade in the future for far less outlay?

Absolutely, @dannybgoode beat me to it.

I had all kinds of trouble connecting to Roon to my network consisting of Comast internet and a Orbi mesh network. Roon was running on a SGC i5. It would never work until I inserted a unmanaged switch after the Orbi device. Once I hardwired both my i5 and my dCS Upsampler to the new switch everything was rock solid. Netgear Orbi could never ever answer why it would not work plugged directly into one of the Orbi ports and required an additional switch.

1 Like

The SGC devices are outstanding units with super support and you don’t have to purchase a keyboard and mouse to set up it up like a NUC. I would never use this items again.

I picked up a simple switch a while ago but figured it wasn’t necessary since the Orbi has enough jacks. I’ll try it and post how it went. Thanks, Still-One

Originally I got the SGC box because it had better reviews than most home-baked NUCs. Don’t know if that’s the case anymore though. Don’t want to spend half a lifetime researching this. Got a link to good site to go to? Or any specific recs? Thanks Danny

@Still-One So outstanding that after 3-4 years you have to buy a whole new one…

@Stephen_Brill - I went rogue and built an unofficial MOCK server using a Ryzen 3400G and a microATX board and case and it’s been bombproof - 100% reliable. However, given the lack of official Roon support I would not necessarily recommend this route.

Apologies, I know it is in the Knowledge Base somewhere but can’t put my hand on the specific link - there is a full page on what NUC’s are officially supported. @ged_hickman1 may be of more assistance here.

By googling “roon nuc” :grin:

1 Like