"Can't connect to Roon search" with two specific artists

Roon Server Machine

NUC8i5BEH with 16GB RAM running ROCK early access

Networking Gear & Setup Details

BT Smart Hub 2 + Netgear GS108 switch
Everything wired with CAT5E

Connected Audio Devices

Linn KDS/3 ethernet
PC remote ethernet

Number of Tracks in Library

81252

Description of Issue

If I search for either Orbital, or Philip Glass, and hit return, I get “Can’t connect to Roon search” within a couple of seconds.
However, if I don’t hit return, the search is successful in the list that appears beneath the search box.
I get this whichever remote I’m using - iPhone 13 Pro, 11 inch iPad Pro or PC running Windows 11 Pro.
I can work around this by remembering to never hit return when searching in general, but I prefer the bigger results screen on the iPad when I do hit return.
I’ve rebooted everything with no improvement. Searches for other artists are fine.

Other points to note:-
I use Qobuz as well as locally stored files. Both Orbital and Philip Glass releases are well represented locally. If I disconnect from Qobuz I still get the issue.
I imagine there are searches for other artists could cause similar problems. If I find more, I’ll add them to this post.

I would be grateful if others could try the same searches. I get the error message 100% of the time when looking for these artists.

Thank you for any help

Michael

I think it’s timing out, rather than failing to connect. In lieu of any “better” replies, try changing your DNS to 1.1.1.1 or 8.8.8.8, this may well speed things up a bit.

I’ve just tried 1.1.1.1 with no success (DNS was set to 9.9.9.9 before). I get the failure message about a second after hitting return with either DNS setting.

Michael

It was worth a try, and 9.9.9.9 is a good choice as well.

1 Like

It was indeed worth a go - thank you for the suggestion.

Michael

@Michael_Curtis the issue seems to be in the cloud service. Would you mind resetting your roon core and trying again? The issue will likely still be there, but it can help us reproduce it.

1 Like

@zenit thank you for your reply. I’d already tried a restart of Roon Server and a reboot of RoonOS to no avail.
However, I just rebooted the OS again, and after it came back up I was promoted to update to the latest early access version. I did so and, lo and behold, the issue’s gone.
I guess something got untangled locally (unless there’ve been changes on the server side too) but whatever it was, it now seems to be ok.

Many thanks for your help.

Michael

1 Like

We pushed a fix on the cloud at the same time, happy to hear that it works. Happy weekend :slight_smile:

2 Likes

Thank you - and you too!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.