Can't connect to roon server

Roon Core running on Windows 10-64.
Roon client running on other Windows pcs and phone.

I was all set on Roon. and then needed to change some configs on my NAS, and my ethernet adapter, and now i can’t connect to Roon server any longer. I have followed all the other advice from other posts, and have even gone as far as uninstalling my Roon client. When i did that, it asked me to choose a server of course, and it gave me the option to connect to my Roon Core (so it did see it on the network), i chose it, and then Roon hangs with its icon buzzing in and out.

Choose RoonCore scrnsht.2

Two more bits of info:

  1. I also checked firewall settings re: roon apps:

On my client pc, i see the following:

on the RoonCore, HOWEVER, i see two instances of roonappliance.exe one with public checked and one with private checked, but only the private one has the checkmark out in front of the name. Hmmmmmm…

  1. I also had disconnected then remapped the network locations that my Roon Core would be looking for music, but i figured that shouldnt affect anything, at worst i would have to reconfigure the network location for the music and rebuild the Roon database. So i dont think this is the cause of the problem…but sharing in case i may be wrong.

Try turning off the firewalls on both machines as a test to see if it then works. If so, then you know that the firewall settings are the issue.

did that too. also checked all appropriate windows services are running.

thinking i may have to try uninstalling/reinstalling roon core.

I’m constantly having to reset my ROCK database after every upgrade and if I monkey with the NUC ethernet connection et at all. Not sure what it is and why. In any case, I always make sure now I have a recent backup before i do anything, so I can reset the database, reload codecs, and then restore from the backup. It’s the only thing that works for me, having tried all the modem resets, etc.

i can try that to see if it helps me - i do have a backup, what does ‘resetting the database’ entail? is that a full uninstall/reinstall? is that what you mean?

You can access the web view of the ROCK OS I’m taking it? (i.e whatever ISP it happens to be)

Then if so, go there and there’s an option to reset your database. It wipes clean all of your settings. You’ll then need to reload codecs (done via SMB on Mac or equivalent on Windows) and then when the Roon remote asks to reconnect again and you say yes, it will go to a page to enter password etc, but there’s an option to restore from a backup.

I think there’s a funky DNS thing going on with certain systems where it gets stuck and needs to start from clean. Slow and frustrating, but I have it down now where before I touch anything around ROCK or the NUC (hardware or software) I make sure I have the backup in order. Just an uneducated guess.

OK, so i completely uninstalled roon server and it works now. (i had to include removing settings too) this is pretty miserable, but at least now i am back up and running.

Yep. Time consuming. I’ve been doing it for every update, big for small, or if I need to disconnect power from the NUC. It’s been suggested it may be a hardware (RAM?) malfunction. Going to rebuild the NUC into a fanless case soon so may get some new RAM at that time, recheck bios, etc.