Cant connect to Tidal or Qobuz

Using Roon ROCK - Intel core i5 NUC. OS is Version 1.0 (build 174) stable - Roon server software is: Version 1.6 (build 416) stable

I just changed internet providers and everything is working well except the Roon client on my Windows 10 desktop PC. I can connect to my local library on a NAS server and play music normally through Roon. I cannot login to either Tidal or
Qobuz (I have accounts with both) When I try to login to these services via the Roon interface I receive the following error: “Network error: Please check your connection” in red box. I can login in to these services via a browser but cannot login through Roon.
Also,whenI go to Settings/Account - I receive the following error: “Error retrieving account information”

The Roon client, Metrum Ambre Streamer, and Roon ROCK NUC are all connected to the internet router via Ethernet.
Everything worked perfectly prior to changing internet providers

The Issue summarized

  1. Cannot access Account information via the Roon client
  2. Cannot login to Tidal or Qobuz services via the Roon client

I have un-installed and re-installed the Roon client with no change.

Hi @Don_Hampton,

Since experiencing this issue have you tried rebooting your ROCK Core machine?

When you switched internet providers did you also switch networking equipment? What kind of router is in use? Are you using any switches or other networking gear?

Can you access the ROCK Web UI?

I have rebooted the ROCK.
When I switched internet providers, I did install a new router. It is a Netgear Nighthawk X4S. I am using a switch behind the router - it is a Netgear GS608 and was in place and in use with my previous router. There are no other network devices.
Yes, I can access the ROCK web UI.
I can access Tidal throught the Windows Tidal app and I can access Qobuz through the Windows Qobuz app. I just can’t login to Tidal or Qobuz from within the Roon client.

Hi @Don_Hampton,

It sounds like there is something regarding the new router that is preventing ROCK from accessing the external network.

Can you verify if the behavior is the same if you bypass the switch and connect the ROCK directly to the router?

– Noris

A snapshot of the rock web GUI page might be of help.

Sounds like a dns setting issue. Are you using fixed IP address?

The router is in another room and away from the ROCK. The router connects to the switch in my office where the ROCK is.

I’m using DHCP - not a fixed IP

OK just noticed the netmask, gateway and dns server are all wrong and associated with my previous router.
So How do I change that?

ok, got it - changed to static ip and same ip addr - then set the gateway, netmask, and dns properly - All is well - thanks for leading me , I appreciate it

1 Like

Sometimes a picture can paint a thousand words. While DHCP should work fine IMHO servers should be using Static addresses.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.