Can't connect to Tidal; Tried all Roon Support suggestions I can find [Solved]

There was an error, please check your account settings–is the gist of the message I get. I have deleted Roon/cache, deleted and reloaded Roon remote, rebooted computer. Yes, I can access Tidal through the my browser. Unless I have missed something in the forum pages, I’ve tried everything you’ve suggested.
Thanks for your help.

Hi Stephen,

Did you close Roon (or Roon Server) core and restart the app?

Cheers, Greg

I had done that before but did it again and Tidal loaded. As with all things digital, the rebooting sequence is critical.

1 Like

I had what appears to be the same problem. Restarting Roon, restarting the Mac, deleting the cache – none of these helped.

I finally looked in the Roon log files, and saw this:

12/22 09:46:03 Warn: [tidal/http] failed: 404
12/22 09:46:03 Warn: [tidal/http] {"status":404,"subStatus":2001,"userMessage":"Session [62b4e049-94b1-40ab-9aea-dedf8c6a359b] not found"}

This suggests to me that Tidal expired the session token Roon was using.

Reentering my Tidal credentials fixed the issue.

Hope this helps someone else solve their problem.

I just had this problem occur yesterday, Dec 21. Tidal had worked post-update, no changes to my system recently. Core is on Windows 10 on an i5 NUC.

Verified that Tidal direct had no problem.

Reentered Tidal username and password, this took care of the problem.

(@Mike – note that this was a Windows core, skimming this thread and your answer I think it was mostly Linux or Mac.)

I wonder if there is a way Roon can post a message like, “Tidal session expired. Please re-enter Tidal Credentials” in cases like this. The program is certainly capturing the failed state in the logs.

1 Like

Been using Roon for over a year. First time this has happened … says “failed to log in to Tidal”.

Hi Jason,

Moved your post here since it seems to be the same issue.

Try reentering your Tidal user name and password in Settings > Services and log back in and see if the helps.

Cheers, Greg

Okay thanks.Logging off and on solved problem.

Agreed - would save time, I spent an hour rebooting etc thinking it was system / software issue - I later realised that I had re-enter username and password - all solved within a minute!