Can't Copy Codecs to Roon Rock OS w/PC

Hello Kind Assistant

I have an Intel NUC8i3CYSM1 and I installed Roon Rock on a 256GB M.2 SSD. It also has a 1TB hard drive that I plan to use for my music. I first installed the latest BIOS on the NUC. Although the installation of the OS went well, and I formatted the hard drive for my music files, I am at a loss for how to copy the codecs to the OS. I downloaded the codecs to my PC and unpacked them with no problem. I have seen a couple of videos where the copying is done, but both of them used Macs to do it and I have nothing but Windows 10 PCs. I can’t access the unit by searching for \rock\ in Windows Explorer - nothing comes up although I can use a browser to access the Roon Rock System Status page. When I click on the “Roon Server Software > Missing Codecs button”, I am sent to the “Roon Knowledge Base > Roon OS Mmissing Codecs” page. This is where I am told to access Roon OS’s Data Directory by “Windows - In Windows Explorer, type \ROCK”. Unfortunately Windows Explorer finds nothing when I do this.
I hope someone who has used a PC to do this can help me, because at this point I have no idea what to do.

Maybe this information can help:

I followed the instructions and enabled “insecured guest logons” under
“Computer Configuration > Administrative Templates > Network > Lanman Workstation > enable insecure guest logons”
but I still couldn’t find or access the Roon Rock by typing \rock\ in the Windows Explorer.

Did you reboot the Windows 10 machine after your changes? Does doing change anything?

If not, you may have to enable the SMBv1 support too.

SMBv1 not installed (enable it with Enable-WindowsOptionalFeature -Online -FeatureName SMB1Protocol)

As I don’t have Windows 10 or a ROCK machine I can’t be of more help here.

I have to enter \ROCK.It should be double slash then ROCK then slash.

Use \\\ for two \\ to show-up or mark the term as preformatted text (`Preformatted text`). Have a look at the preview window at the right side.

Thank you BlackJack & Outlaw for responding. I followed the link BlackJack sent me, did what was suggested, and was able to access the Roon Rock and copy the ffmpeg folder to the \data\codecs folder, but the Rock stil shows “Missing Codecs” under the “Roon Server Software” heading. Any suggestion how I can overcome this?

According to you should copy the file ffmpeg to the codecs folder not an entire folder.

Hint: You may have to uncompress the downloaded archive twice.

Hi @Ed_Incleve,

I would make sure to reboot your ROCK after copying the file over.

There should just be one ffmpeg file listed in the codecs folder and I would make sure you’re extracting it with 7-zip.

Other unarchiving tools have sometimes failed to properly extract this file. This is what it should look like:

Thank you noris, I did what you said and everything looks OK now. Btw, the ffmpeg file came from a folder “ffmpeg-4.2.2-amd64-static”. Is this the right file (ffmpeg) to use?

One other question, do I have to have a current subscription before I copy my music to the 1TB hard drive. I haven’t subscribed yet, because I haven’t decided whether to go yearly or lifetime. A couple years ago I used the one month trial, but I currently use an Elac Discovery Server with Roon Essentials, so I know I will like the full Roon. I think I saw somewhere that I can’t copy my music files from Essentials to (Full) Roon. Assuming that’s true, it’s the only thing I don’t like Roon.

Hell @Ed_Incleve,

Yes, this is the correct one.

Yes, this is correct. There is no way to migrate the Roon database from Essentials to Roon. ROCK will have to be set up as a fresh database and then you can point ROCK to your music files:
Add Folders By Path Guide

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.