Can't delete a duplicate album

Here’s a tricky scenario. I found that in one folder of an album, files were saved in both aiff and flac. So there appeared two albums on Roon, with one shown as duplicate. I went into the storage and deleted flac files. And then went to Roon and tried to delete the duplicate album. Went through the warning, yes and yes, and error message pops up saying that the files are not found. After this point, This broken duplicate album can neither play properly nor be deleted. It’s just stuck. I restarted the Roon, force rescanned the entire music storage with no avail. I’m a perfectionist and I don’t want to ever see a broken album on my library. “Hide album” option only hides it in the Overview (first page), but not in “view all” mode or inside the artist catalog. What should I do?

BTW, inside the Album Editor, “Re-scan”, “Re-identify”, “Re-analyze” album functions do nothing for me. I never figured out how to get it to work.

Hi Andrew,

I’ve seen this in the past and usually restarting your Core (Roon or Roon Server) fixes the issue.

If this doesn’t work for you, we should flag @support to help out.

Cheers, Greg

1 Like

@Greg, you were right. It cleared up by restarting my ROCK core. Thanks!

But this is a minor bug that needs to be fixed. Also, “Re-scan” “Re-identify” “Re-analyze” functions need fixing too.

Hey @hgim82,

The re-scan/identify/analyze functions are typically pretty instant processes, and often times if there are no substantial changes to the files there will be no visible change. Are there any other examples of times you’ve tried to use these functions and expected a change but no change occurred?


@dylan, well I only use it when there were problems like I described above. I don’t recall any problems resolved by clicking these buttons. Furthermore, what are the differences? Shouldn’t all three actions done at once?

Hey @hgim82,

Re-Scan checks for changes to file tags or embedded artwork, so this would be used if changes were made to that in your files.

Re-Identify tries to match the album to one in Roon’s database.

Re-Analyze checks the tracks for corruption and does another round of audio analysis on the tracks.

These are mostly used if you make changes to your files that Roon may not be picking up immediately. In the case you mentioned above, it sounds like something else may have been occurring here. Is this the first time you’ve experienced this behavior when deleting an album?


@dylan, yes I understand the description, although I don’t understand why they have to be three different functions.

Since you asked, I’ll give you an example. I go to the library storage, and delete a few tracks. “Re-Analyze” should immediately note that these tracks are missing so should disappear from the Roon database. But nothing happens. Most of the times the edits are immediately applied so I am not complaining. When the problem happens, on the other hand, I never got it fixed by any of these buttons either.

Hey @hgim82,

Each function serves a different purpose and there may be cases where you’d only use one or two of these instead of all of them.

In this specific example, there is something else going on. When media is deleted, typically this will reflect automatically in Roon, so those functions shouldn’t be necessary (and aren’t meant to be used with deleted media).

Can you give me a little information about where your media is stored? Is it on the Core machine? On a NAS? How large is your library?

What kind of Core machine are you using?


@dylan, I have also noticed that my Roon doesn’t automatically scan new music saved into the storage. I have to manually scan the storage folder.

This is a new issue since I installed a new ROCK core machine in a NUC. The storage is a network drive. My home is a campus housing so there is an internal network set up so I can easily mount the storage by smb without a need for a separate NAS. My 6TB storage is connected to a desktop MacPro which is under the same subnet as the ROCK core.

Any troubleshooting tips?

Hey @hgim82,

Can you give a little more information about your network setup? What networking hardware are your devices connected to and how are they connected?

Can you share a screenshot of Settings > Storage, as well as the edit screen for that networked drive?


@dylan, @support. As I said, I live in a campus housing. So long as I plug in devices to the ports under the same subnet, they work just as a subnet set up by a network switch (basically there is a network switch outside the house connecting to different ports on the wall). I can mount the music folder onto the Roon core using smb protocol. Music is stored in a hard disk which is connected to a MacPro using thunderbolt connection. Below is the folder setup.

Note that in my previous setup, everything was the same except that the Roon core was set up on another MacPro machine which mounted the music folder exactly the same way. Then Roon instantly picked up new music I put into the folder. The only change is to use a dedicate ROCK core now, and it doesn’t work as before.

@dylan, @support, To help you understand better, here is a graphical layout in my house :slight_smile:

I appreciate the update here, @hgim82!

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce this by adding a file to the watched folder, then scanning the watched folder so it picks up in Roon? Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.


@dylan, I just did. Again, I had to force rescan the folder for Roon to pick up the new music. The time stamp must be 10:45-10:46pm. Let me know how we can raise the diagnostics.

Although I doubt it, I wonder if this has to do with the fact that ROCK/Linux OS cannot write on MacOS-journaled formatted HD. It shouldn’t be because Roon only reads the music and writes onto the database on ROCK core, but just wondering.

Thanks. @hgim82!

Now that I have the timestamps, diagnostics have been enabled on your account. The next time your Core is active a diagnostics report will automatically be generated and uploaded directly to our servers

Once that’s been received, I’ll be sure to update this thread and pass the diagnostics over to the team for further analysis.


Hey @hgim82,

The team is still investigating here, but we were hoping you could perform a test for us that would give us some greater insight into what you’re experiencing here. Please see the steps listed below:

  1. Make a backup of your Roon database.
  2. Disable the current watched folders in Roon.
  3. Attach the external drive directly to the NUC and enable it as a watched folder (Note - It is important you don’t have both watched folders active at once).
  4. Add music to the drive.

Does this automatically update, or do you still have to force the scan?


@dylan, my external HD is thunderbolt so cannot be directly connected to NUC. Other than I have to force rescan everytime I add new contents, everything works fine so I don’t want to hassle with many experiments.

I can tell you that, after I add the new contents in a single album folder, I can have the updates only by the force rescan of the whole thing. No automatic pick-up, or “re-scan album”, “re-identify” album cannot pick up the new contents.

I suggest that you do the experiments on your end.

@dylan, it looks like I’m not the only one. Similar problems with NAS HD users.
Adding new music.