Can't delete albums from Library

Roon Core Machine

Rock 16gb 7i7

Networking Gear & Setup Details

N/a

Connected Audio Devices

N/a

Number of Tracks in Library

58k

Description of Issue

I have some albums that Roon won’t remove. They are no longer in my Qobuz favourites, yet they show up in Roon and I can’t remove them, says they are not selected when they are .

Any help appreciated. Probably more like this I haven’t noticed I bet.

Can you add them? Seems like they are in a limbo state.

Nope doesn’t give me the + option

1 Like

Have you tried logging out of Qobuz?

1 Like

Once in a while, I have the same experience.

What has worked for me, is to favorize the album in Qobuz again, (and if necessary trigger a manual synchronisation between of Qobuz in Roon).
In principal, your album will now be reinstated in Roon in normal status.
Then you can (try to) remove the album again.
Hope this works for you to.

Dirk

2 Likes

Not yet I can try that when I’m back home, but not sure what that would achieve. It’s syncing on with Qobuz for everything else.

1 Like

Will try that .

1 Like

No, me neither, but I couldn’t think of anything else. Dirk’s suggestion sounds like it might be more useful.

1 Like

When I’ve had this, I think I did the following:

  1. Check on the Qobuz app (not Roon) it the albums are “favourited”. I seem to recall that they usually weren’t.
  2. Favourite them in the app, then force a resync in Roon
  3. Delete the albums on the Qobuz app and then force a resync in Roon.

If, at stage 1, they’re showing up as favourites, a move straight on to stage 3.

2 Likes

Last time I had this ghost album state, a cache clear and Core reboot fixed it for myself.

Just got back home and Qobuz is down so can’t try this out any of your suggestions.

Adding and removing worked thanks guys…

3 Likes

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.