Can't delete/remove Tidal album from library

Description Of Issue

For the first time (and only for this one album), I cannot delete/remove a Tidal album from my library. No matter if I select the Remove from album menu item from the Album page, or drill further down into the edit menu and try to delete.

Funny thing is, I believe I accidentally clicked where I wasn’t supposed to the first time I tried removing it, because I saw a screen I did not recognise. Can’t say much more about that screen, as it just went past quickly, but I believe the individual tracks were listed with minus icons and there was some red text in that UI. Never seen ever before, or since.

I am pretty sure something happened on that screen, and the result of it is that I now can’t remove this one album from my library.

Diffuse as hell, I know, but hopefully someone has sound advice for me.

I’ve occasionally seen this, usually if I try and remove an album I have just added and before playing it.

A reboot of the core fixes it for me.

1 Like

My NUC running ROCK has become so much of an appliance that I didn’t even consider to try that. Should be the first thing to try. Always. It did indeed work like a charm. Issue solved.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.