Can't enable chromecast anymore [Roon Investigating]

Roon Core Machine

Imac 24-inch, M1, 2021 MacOS Big Sur 11.6

Networking Gear & Setup Details

Telenet CH7465LG-TN

Connected Audio Devices

Master&Dynamics MA770

Number of Tracks in Library

Description of Issue

Got the Master & Dynamics MA770 for two weeks now when I’ve got them installed them and Roon and it worked from the first moment. It has been working for three days. Only problem that i had was that Roon stopped playing and i had to switch it on a couple of times each day.
I’ve been away for one and a half week, when returning started roon but was unable to select the MA770 audio zone. Despite that roon said in the audio settings that it was connected.
Resetting the modem ( router and wifi) didn’t solve the issue, factory resetting the MA770 brought i back in the audio setting but it isn’t possible to enable it. In the log i find next error

10/05 10:54:21 Error: [cast/client] [Master-And-Dynamic-M-5d291d8a1c3a3ef883a27e74645cfc14._googlecast._tcp.local] Failure to start Roon App on device
10/05 10:54:21 Error: [cast/client] [CastReceiverChannel] Failure to start application 6242A3BE on device: {
“reason”: “CAST_INIT_TIMEOUT”,
“requestId”: 5319,
“type”: “LAUNCH_ERROR”
10/05 10:54:21 Error: [cast/client] [Master-And-Dynamic-M-5d291d8a1c3a3ef883a27e74645cfc14._googlecast._tcp.local] Failure to start Roon App on device

Also completely removing roon from the mac and reinstalling also didn’t help still got the problem.
Any idea how i can solve this?

Hey @Hans_Claerhoudt,

We’re very sorry you’ve ran into this issue… we’d love to lend a helping hand :nerd_face:

Could you please let us know how the Master & Dynamics MA770 is connected to your iMac (the Roon Core)? You mentioned it appears in Settings → Audio, When you say it’s impossible to enable it, what do you see? Could you please send us a screenshot of Settings → Audio?


The MA770 is connected through WIFI and the source on the MA770 is CAST.
I can cast music through the chrome browser without any problem.

When a push on enable nothing happens
If I do that with the imac speakers it works directly
The screenshot below is after trying to enabling the MA770 and the Imac speakers


A post was split to a new topic: Chromecast Devices can no longer be enabled in Roon

Hey @Hans_Claerhoudt,

Thanks so much for following up and for sharing the screenshots we’ve asked for.

If I could ask for one more thing would be logs. Could you please zip up a set of logs (instructions here) and upload them in our drive?

Once you got a chance to do that, could you please let us know here? :pray:

Hi Rebeka,

Logfiles are uploaded to the drive


I hope this can help you

Hi @Hans_Claerhoudt, I just wanted to let you know our team is looking into this and we’ve reached out to our QA team for feedback. We’ll be in touch soon!

1 Like


Is their already any news from the QA team about this issue?

1 Like

Any news about this issue?

No, we’re still waiting for a reaction.

If ROON no longer supports Chromсast, this is very bad!

There is still no answer from ROON technical support on this issue?
If this continues, I will cancel my ROON subscription .

No Yuriy,

Still no answer, seems to be not that simple to solve it.

It is not clear to me how roon can ignore the support of such a popular protocol as Chromecast - especially since earlier roon provided this support

I do have the same problem. I am using my windows notebook as roon core. I have a few chromecast audio and chromecast HDMI plus one Google Home Mini in my network. They are all shown in my roon audio settings. But I am not able to enable only one of them.
I am in the roon trial period and I think I would love roon, but without being able to stream audio to my chromecasts (HiFi stereo) it makes no sense at all.

I hope this issue can be fixed soon.

Happy new year,


Hi Stefan,

For you to a happy and prosperous 2022!!

My problem is a little different, when a push at “enable” nothing happens at all and I’m working on a mac.

Perhaps it is better for you to start a new cas with your specific problem.

Concerning my problem I’m very afraid that there isn’t a simple solution to it, around the 20th of october, after sending the log files, they’ve answered that the team was working on it and that i would hear from them soon. But I’m still waiting for an answer.

I’ll hope that you will have more luck.


Hi Hans,
thanks for your reply.
I will do this.

However, I think the problem is very close to yours. I have some chromecasts, some are audio and some are video and there ist even a Google Home Mini.
None of them is working.

In Audio when clicking on “enable” they behave differently:
CC Video: The Roon App-Screen appears on the TV and wants to start but the circle spins endlessly and nothing happens. It doesn´t start and the chromecast will not be enabled.
Google Home Mini: The mini makes a sound but nothing happens. The chromecast will not be enabled.
CC Audio: Some behave like yours: Nothing happens at all… Some behave like described above. I will try to find the difference (WLAN vs. LAN?) and then I will start a new case.

Maybe it has to do with firewalls?
If I find a solution, I will tell you.
Maybe you could contact me also if you can solve the problem.

Have a nice weekend.


Hi Stefan,

everything worked fine with me until Roon did an upgrade in september, after that chromecast was finished. Nothing changed with my firewall or in my LAN.

Some other had the same problem but they did an upgrade for the chromecast device and that worked for them.

I’ve upgraded everything in my Lan that could possibly had something todo with the problem but nothing worked.
So I’m hoping for you that you have more luck.



I just noticed several of my chromecast devices are no longer in my audio list

HI Brandon,

Are they not in the audio list or are they in the list but you can’t enable them?