Can't enable Dragonfly Red on Elementary OS

Core Machine (Operating system/System info/Roon build number)
Mac OS 10.9.5, Roon v1.8 build 753

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Running on home WiFi

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)
USB Dragonfly Red

Description Of Issue
My AudioQuest Dragonfly Red is listed as a device in Settings>Audio, but when I click “Enable,” it says “Device not found.” The Dragonfly is connected to another computer running Elementary OS using ALSA. It works well when in Windows but can’t be used with Roon when I’m working in Linux.

Note: Also had this issue before Roon 1.8.


Silly question: and you are running Roon-bridge on elementary?

Yeah it is running, and all the audio outputs are showing in Roon! I’m just unable to enable my dragonfly.

Hmm, works fine with a Dragonfly black on elementaryOS 5 fully updated, roonbridge installed with the easy installer.

Strange, thanks for the quick reply! I’ll fiddle around with audio drivers if I can.

Edit: Just fixed it, I had the pulse audio daemon running and uninstalling pulse audio solved the problem.

Strange indeed, my was a fresh install of elementaryOS, but good you got it working!

Yeah I’m not sure why that fixed it, I reinstalled pulse audio since it’s needed for audio in Firefox and some other apps that don’t support ALSA anymore. Though not an ideal solution, I can disable and enable my dragonfly in pulse audio when I want to listen to music.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.