Can't find Audio devies [Resolved - Reinstall and restore backup]

Hi Geoff

All the music in on a external HD ( which all the other programs / file managers and I tunes find

is that what you mean ?


I’ll try to help you think about possibly relevant information to supply to the community:

What modem and/or router model numbers are you using?
Are you using DHCP, reserved or fixed network addresses?
Are any firewalls or such configured in said devices?
Are there switches between your network devices, and if so, details please?
Is the network address space the same for all Roon relevant devices?
How is your Mac connected to the network?
What is SonicStream, how and where is it connected?
What is Audioengine B1, how and where is it connected?

How do you expect everyone to know?

1 Like

I don’t expect everyone to know and apologies for implying that. I was having issues and reached out to the support group assuming it was product support rather than community and I really appreciate the help.
I will do my best to answer your questions:
My mac is connected to the network directly via Wifi to a Virgin SuperHub cable modem/router with out of the box configuration - i believe it does the DCHP stuff - and no additional switches, fixed network addresses etc and firewall on my mac. All devices are on the same network address space. SonicStream is a radio streaming software I use occasionally but not at the same time as Roon. AudioEngine B1 is the bluetooth receiver for my hifi.

I don’t think my problem, does not seem to be related to network configuration. Everything was fine until this morning, when I tried to create a new playlist. Then the mac started showing a speeding wheel and Roon was not responsive and I had to kill it and restart. Since then it cannot see any audio connections/devices, even though all other applications (such as iTunes, Tidal, and Finder) can see them.

Any suggestions/ideas would be greatly appreciated.

Your Roon library is corrupted. Do you have Backup?

hi xxx

Yes, Roon did one - is that what you mean ?


Hi xxx

But Roon won’t start - so I can’t actually do anything

Try these instructions:

What kind of system drive do you have in the Mac? HDD, Fusion drive, SSD? Getting a “spinning beach ball” is not a good sign.


I have not Idea what a RAATserver is - I 'm just a user who brought Roon to play music !
but I repeat - Roon won’t open so I can’t to anything with it
The mac has a fusion drive and all of the music is on a external HD

I’m of the opinion that I just have to bit the bullet and assume that roon has failed

all other programmes are working as expected ( no Beach ball errors )

Screenshot 2021-07-26 at 07.56.44

If @wklie’s advice doesn’t help, I would -

  1. Delete your current Roon installation. Delete everything including your Roon library. Follow the instructions here for finding all Roon related files
  2. Reinstall a fresh copy of Roon. As I remember, at install time you will be asked if you want to Restore your library. You can do it then or any time after the new Roon is up and running.

You will lose any changes you have made since your Backup, but those are probably gone now anyway…

Thanks XXX
I suspected from the start that I would need to do a re install
I can’t try Wilkis help as roon won’t start

I will give roon another go and see how much data I have lost ( Names etc I have amended and added artwork ) - if it fails it’s back to I tunes


1 Like

Tagging @support, in case they have another, less destructive, solution.

Good luck.

I recommend you read the instructions again. It’s done after exiting from Roon.

4 posts were split to a new topic: Audio devices missing, Wake On LAN issue [Resolved]

did a destructive delete and re install ( could not see any other way around it )
and this is how my audio screen looks ( like it did yesterday morning )

Now I have to start rebuilding my database !!!
Life is too short for this stuff…

So…roon is back and luckily ( very luckily ) I had back up soon on 23.07 !!!
Would still like to know how this happened but I thank all those who responded and tried to help

1 Like

Thank God, was seriously worried that this wasn’t going to end pretty…

I’m using Roon 1 3/4 years, tinkered around with RaspberryPi endpoints running Roon bridge on Diet-Pi and Ropieee operating systems, am using convolution and upsampling, usually shut down my core server over night, and fortunately never had any comparable problems - knocking on wood until knuckles hurt right now…

It happens because, in spite of Roon blaming hardware problems for a corrupted library, I suspect there is also at least one software bug that causes problems.

I’m betting that Roon software doesn’t take any checkpoints before undertaking a critical update on their database, and so if a problem occurs there is no way to back out (or even recognize) an incomplete operation.

Only an opinion.

Back up your library frequently and because of an inadequacy in Roon’s Backup logic, I recommend backing up to several locations on several schedules and with different retention periods.

No thats good advice - my room back up is somewhere different but no harm in doing more than one

Hi @Ray_Thomas

I’m glad you were able to get up and running here!

It’s hard to say exactly what happened at the moment, but it appears that your database got into a bad state. We’ve seen this happen for a few reasons like failing hardware, unstable power situations. Now that you’re up and running I definitely recommend continuing to make regular backups, and I’d also run some tests on your RAM and SSD to see if there might be any signs of them failing.

If you see any issues return please do let us know!

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.