Can't find HQPlayer


My Setup:

Core machine:
sonicTransporter i7 server, OS Linux, with Roon Core and HQPlayer Embedded installed
SSD-disk 2T connected to sonicTransporter

Streaming device with dac:
La Rosita Gamma HD with NAA microRendu

Connections are LAN from modem/router Arris TG2492LG-ZG and router Fritzbox! 4040 (for WiFi to iPad) using switch from D-link via server to streaming device

Today I couldn’t open the HQPLayer Configuration page. The way I always do it is by opening the management page of MySonicorbiter, then I go to settings>HQPLayer Server> HQPlayer Config and then the page opens but not to day. Can’t even fill in my password.
This is what I see:

I want to know how I can play my music without HQPLayer for the moment without removing it from my sonicTransporter.

Thanks for help, Bert Dijkstra.

Wouldn’t it be just a case of making sure that the microRendu is setup for Roon use, and then just Enbling the microRendu in Roon and choosing it as an output.

Hello Rugby,

Sorry if I don’t understand your solution but I want to understand how enabling the Micro Rendu in Roon? Is there a button somewhere in the settings from Roon. I need more explanation. Besides the Micro Rendu does work as output from the beginning of 2019 with Roon. The problem is that suddenly (after a reboot) Roon can’t find HQPlayer anymore.

Try power cycling the ST (power button on ST-turn off then on ).
Sometimes that works when reboot doesn’t.

Hi @Bert_Dijkstra,

If you are trying to access a feature in the SonicOrbiter Web Interface and it is not working, I would reach out to the SonicTransporter support team for further assistance.

Hi Norris,

The SonicTransporter support is minimal. I did ask if a delete and reinstall from HQPlayer Server could help and how to do it. The answer was: try reinstalling HQPlayer. Well that makes me happy :grimacing:!

When I looked to the Settings> Setup in Roon I noticed that HQPlayer could be added (see screenprint). Yes I did this in the beginning of 2019 and it functions until last week. Can I hit the button again and could it be the solution or do I get more troubles. The whole situation makes me very insecure.

Bert Dijkstra

Hello @Bert_Dijkstra,

Yes you can click on the button to add HQPlayer, I will also provide our article on setting this up:

This has not been my experience with Small Green Computer support in the past, usually they are very good. I would click on the “Contact Us” button at the bottom of their website and reach out that way, perhaps you are using another method to contact them:

Hello Noris,

Thanks for your reaction and support.
Unfortunately I don’t use HQPlayer Desktop but 4 Embedded. The implementation is different.
My contact with SGC goes via Andrew Gillis, I thought the best person to give me support, but after a week there is still not a single solution. Roon can’t find HQPlayer but both are installed on the same device from SCG. Working with the managementpage ends with the step: open HQPlayer Config. My suggestion with reinstall HQPlayer(d) server with support from SCG is one quote: Yes you can reinstall. That’s not the support I need.

Greetings, Bert Dijkstra.


Thanks all for helping me. I just got my HQPlayerd working. Hopefully for a long time. I did write a manual how to reinstall HQPlayerd on a sonicTransporter. You can find it in the Topics from HQPlayer. This was what I needed from SGC but I had to find it out my self.

Greetings, Bert

1 Like

Hello @Bert_Dijkstra,

Thanks for letting us know that you were able to resolve this issue on your end!

Do you mind linking this manual here in case others have similar issues?
If you have any other issues with Roon, please just let us know and we can take another look, thanks!


I had some troubles with HQPlayer on my sonicTransport 7i. I couldn’t reach the Config page and Roon couldn’t connect to my network player. The advice was: reinstall HQPlayerd.

I made a manual:

Manual for reinstalling HQPlayer on sonicTransporter and a NAA
sT= sonicTransporter
HQP= HQPlayer
NAA= in my case a MicroRendu

Remove: > Manage page sT> Apps> Software Manager> Installed Apps> HQP Server> Delete> OK

First check whether the network player (with a NAA) is set up correctly: > Manage page Network Players> Apps> App Switcher> HQP NAA> Active
and optionally HQP NAA> Restart (NAA) HQP

Install: > Manage page sT> Apps> Software Manager> Available Apps> HQP Server> Install> OK
Now the download is visible.
You can now return to the page at the bottom of the download report.
Check if you can go to the Config page: > Manage page sT> Settings> HQP Server> Click HQP Config> you should now be on the Config page
Check whether everything has been entered as you were used to (a screen print is useful).

To re-issue your license:
Look at About on the Config page at the bottom to see how it stands. If it says License: Trial, then you have to upload your License Key.
You go to Key at the bottom of the Config page> Choose file> select your License Key file and upload> wait 10 seconds and you’re done, you can go back to the Config page.
Finally, choose Apply at the bottom of the Config page.
For me HQPlayer worked as usual again.
If something is not right somewhere, I would like to hear about it and I will adjust it.

Bert Dijkstra

1 Like

Hi @Bert_Dijkstra,

Thank you for sharing this guide, it may be useful to others who are experiencing similar behavior!
Glad to hear that you got this issue sorted out!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.