Can't find library or audio devices Roon Legacy 1.8

Roon Core Machine

2011 iMac
OS X Yosemite 10.10.5 (can’t upgrade to later OS)

Networking Gear & Setup Details

Not applicable, my music library is in a external hard disk connected through USB port to the iMac

Connected Audio Devices

Yamaha RXA3070

Number of Tracks in Library

12,000 tracks

Description of Issue

For starters, I can’t upgrade to Roon 2.0 as I have an old Mac OS. :frowning:
I have an iPhone 6 where I used Roon Remote, but it is no longer working as it expects a Roon 2.0 Core. So, I installed Roon Remote Legacy in the iPhone, which I understand should work with the Roon 1.8 Core. However, it doesn’t (see attached images) and Roon keeps telling me that I have the latest possible core installed.

You need the new build of 1.8, which is 1.8 (Legacy).

Follow this guide and download the 1.8 (Legacy) file.

As soon as your core has upgraded to 1.8 (Legacy) Build: 1126. You can download the legacy apps for your phones and tablets.



I managed to install Roon Core 1.8 build 1126 in my mac, however I now have a bigger problem: no audio devices appear in the Settings–>Audio screen. :(((

My Yamaha RXA370 is connected to the iMac through HDMI and before this upgrade it was working fine.

This problem happened some months ago with another upgrade and it was solved quickly with a new build.

Please help !

I just realized that my music folders are not recognized, either. There is no music in my library. If I try to add the folders again, I get an error message that the folder has already been added, but it’s not scanned. :(((

Hey @Alfredo_Freyre,

Ben with the support team, I wanted to check in to see if you’re still running into issues with your watched folders?

When in doubt, give your network and core a hard reboot, and see if your issue occurs :pray:

Hi Ben,

Thank you for the follow up. Unfortunately it’s not working. I have tried everything, including restarting the Mac and downloading again the Roon 1.8 Legacy version (build 1126) and reinstalling it, but the problem continues.

I continue to run into 2 concurrent issues:

  • The Audio screen is empty, no audio devices are recognized and I have no way to add them. Mind you, this happened a few months ago after I installed a software update, it was reported and the following day you guys released a new build that solved the problem for Mac.

  • No music appears in the watched folders. I have even tried to use new folders but the results are always the same, no music is found.

I wouldn’t mind installing everything from scratch. I think that maybe some Roon database or files are remaining in my computer and that is preventing me from making a clear start, but I can’t find them.

Please let me know how can I help you to help me. If there’s any information you need I’ll gladly provide it. Just be aware that I’m not really an expert in Mac.

Thanks again !


Hey @Alfredo_Freyre,

Thank you for the update! Sorry to hear you’re still having issues. A first thought, do you have a recent backup you’d be able to load? A backup pre-dating the issues you’ve recently hit. The good news here is that loading a backup won’t affect the version of Roon you’re running.

Here is more info on this :

Let me know if the above helps :pray:

Roon Core Machine

mid 2011 iMac running OS X Yosemite 10.10.5
Processor 2.5 GHz Intel Core i5
Memory 6 GB 1333 MHz DDR3

Networking Gear & Setup Details

Connected Audio Devices

Yamaha RXA3070 through HDMI

Number of Tracks in Library


Description of Issue

Installed Roon Core 1.8 Legacy build 1126 and all my audio devices dissapeared and the Manage Audio Devices button in Settings–>Audio is not working. Also, even though the storage file path is ok, all my music has dissapeared as well (the files are in my hard disk but it seems that Roon is no longer reading them).

Maybe you need to restore from a recent Roon database backup.

Silly question but have you restarted the Roon Core since the update?

I’ve got the same problem after downgrading.

I’ve ensured permission are ok on my NAS drive for RoonServer user but in the app, it says Error loading folder.

I’ve restarted the core but to no avail.

I’m having a bit of a meltdown with all this tbh

Yes… Several times, in fact, to no avail

There are some peculiar problems for me with Roon on a Synology NAS drive. Roon still ‘remembers’ the old Synology workstation and I can’t add a folder in the Storage settings and get to the ‘root’ or the new Synology name if you know what I mean.

What I will try to do is de-install Roon 1.8 Legacy again, and remove the RoonServer user. And re-install. I’ll see what happens.

Sadly, I get an error too when trying to restore the only backup I have. I would have no problem with reloading my music files and doing all the setup again from zero as long as it works

Tried removing RoonServer user and re-installed Roon 1.8 legacy but still cannot access shared folders in Storage section. I’m running out of ideas…

Hi Alfredo_Freyre, are you using a NAS by any chance?

Hi Shon_Ellerton, no, I just have an external drive with all my FLAC files connected to the USB port of my Mac.

Hi Alfredo,

So if you go into Settings > Storage > then +Add Folder. Are you able to add a folder? I am unable because I get an error loading folder message.

Yes, I’m able to add the folder and it then appears listed in the storage section with a message like “files will be monitored in real time” of something similar, but nothing happens. If I try to Force Rescan the folder, the “thinking” icon appears for a moment but, again, nothing happens.
Thanks Shon

Hi Alfredo. That’s interesting. There’s something very wrong here. I’m going to try to download the latest pre Roon but not the legacy version to see what happens. RoonServer_Synology_DSM7_x86-64_20220216.spk