Can't find my Pro-JEct Pre-Box S2 after upgrading to 1.7

Core Machine (Operating system/System info/Roon build number)

SonicOrbiter Sonic Transporter 2.7 - Pre Box S2 2.12 / Windows 10 / Roon 1.7 Build 500

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)


Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

USB on a Pro-Ject Pre-Box S2

Description Of Issue
Since upgrading to 1.7, Roon has ceased to see my Pro-Ject Prebox S2. I have restarted the unit and the server with no success.

Hi @Alain_Robillard-Bast,

Are other endpoints okay? Can you share a screenshot of Settings > Audio?

If you connect the device to another machine running Roon are you able to see it in Roon?

Hi @dylan! Here is the screenshot. All my endpoints are there, except my main one! :frowning:

I have not tried to connect the S2 to my other computer yet, but will try and will keep you posted soon!

Thanks for the update, @Alain_Robillard-Bast.

If you scroll down, do you see any audio devices from the Nucleus, like HDMI output?

The only other devices shown are my Airplay devices. Here is the rest of the screen.

I have verified on my Mac. When the S2 is connected to it, it does indeed show up in the available device on the Mac. So I came back to my Windows 10 computer and installed the latest, newest drivers for the S2. The computer does see the Pre-Box S2 (listed in the USB Audio Devices), but Roon still does not see it. I also updated Roon to build 505.

Have you tried turning off the firewall and anti-virus running in Win 10 to see if the S2 appears?

Hi @Alain_Robillard-Bast — Apologies, I think I mixed up my reports and thought you were using a Nucleus here. But I see now that is not correct.

As suggested by Daniel, is there any change if you disable the firewall on the Windows device temporarily?

1 Like

Ho! It worked! Thanks! :grinning:

I stopped the firewall and the S2 reappeared - as did an entire block of direct connections to my computer, including WASAPI and ASIO for the S2. So what exclusion should I indicate in my firewall? I didn’t have to in previous versions, right?

It’s not typical behavior I think, cause I had no troubles with my Project S2 after upgrading on my Windows machine. Do you have a non-MS Firewall?

Roon, RoonServer, RAAT should all be exceptions.


Hi @Alain_Robillard-Bast,

As Daniel suggested, putting exceptions in for Roon/RoonServer and RAATServer should do the trick. Let us know if that helps!

Well… I kept on having problems with McAfee.

I had an unused license for Norton 360. So… Uninstalled McAfee, installed Norton. Et voila! Everything is back to normal now. Thanks for pointing me in the firewall direction!

I had no setting to change in Norton 360.


Hi @Alain_Robillard-Bast — I’m glad that things are working for you now! Please feel free to reach out if you ever have any other questions or issues. Happy listening :headphones:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.