Can't find roon ready devices

Hi @Ron_Bierman1 ----- Thank you for touching base with me, your continued feedback has been appreciated!

Continuing forward, I want to first check in and see any new progress or observations have been here, in regard to this behavior you are experiencing with your endpoints/remotes and additionally, I want to ask if you have tested with Norton completely disabled just to rule out that variable as a potential cause.


Turned off Norton firewall and auto protect. Tried ROON again. Still nothing found in either zone. Today, the Android remote, which discovered both yesterday, no longer finds either device today, which =s less than no progress. Fing, Blusound, and Spotify see both ROON-enabled devices. Windows 10 shows all network devices except Node 2 which has Ethernet connection to router.


Thanks for the follow up @Ron_Bierman1!

Continuing forward, can you verify for me that the firmware on the Netgear R700 is up to date. Additionally, can you also confirm if IGMP snooping is active on the router and if it is, would kindly disable this feature and let me know if this action triggers a change in behavior with your devices.


The firmware was not up to date, so I updated. No difference. IGMP proxying was and still is disabled. I don’t understand the relationship between IGMP snooping and proxying, but I don’t see a setting related to snooping.

Also, NAT filtering (secured, not open) is on, if that matters.


Hi @Ron_Bierman1 ---- Thank you for the follow up and updating the firmware on the R700. Very appreciated!

I wanted to touch base with you and see what firmware version is currently running on your BS devices as I know they have released a firmware update recently (“2.16.1”). If you have already updated can you confirm how your BS devices have been performing?


Android app for BS indicates when an update is available for NAD receiver and I always do the update. I don’t remember one this year yet, but I use the app a lot and it isn’t telling me there’s an update. I believe the Node 2 updates automatically when it’s connected, which it always is, except when I sometimes shut it down (without power cutoff) and reboot.
I also removed and reloaded ROON and the Windows Controller for BS in January. So I believe everything is up to date. BS recognizes NAD and Node 2, as do Windows 10, Spotify and Fing… Roon, which I also reloaded in January, hasn’t seen anything but the Windows PC it’s on since last year. I just tried again on Android and PC with no luck. Both go into searching loop. At least the Android app does see the PC. If you sense a little frustration, you are correct.


Hi @Ron_Bierman1 ----- Thank you for the update, the insight and feedback are both appreciated.

So as of now none of the mentioned network based endpoints are appearing in Roon, correct? You are only given the option to select the “system output”, yes? You are running the latest Roon build (i.e build 310)?

When you mentioned that the Android app sees the PC, this is making note that the Roon remote can see the core (i.e the PC), yes?

Additionally, can you provide me with the exact make and model of the core PC?


Yes, System Output is the only play option on the PC running core. ROON plays on that PC. Android phone-app offers System Output or phone. Settings/Setup/Configure loops forever on both PC running core and Android phone running ROON app.

I have Version 4 (Build 310) stable (64 bit) as core on the only PC that has ROON installed.

The PC running core is a Dell AIO XPS 2720 with four Intel i7 processors.


Hi @Ron_Bierman1 ----- Thank you for the follow up, the insight is appreciated!

Continuing forward, may I kindly ask you to please use the instructions found here to send me an update set of your “Roon” logs from the PC currently hosting your Roon core (i.e Dell AIO XPS 2720).

Additionally, after you have provided the logs I would like to have you perform the following tests to see if we can trigger a change in behavior with your Roon core:

TEST #1 - “New RAATServer folder”:

  • Before anything please make a backup of your current Roon DB.
  • Next please close the application on your core machine and any active Roon remote devices.
  • Locate your “RAATServer” folder which is going to be found in the same directory as your Roon database.
  • Rename the entire “RAATServer” folder to RAATServer_old
  • Relaunch the application on the core machine and verify if it sees any of the network endpoints.

[Note: Do not delete the RAATServer_old folder]

TEST #2 - "Different Roon core:

  • You should have already made a backup of your Roon DB from the previous test so no need to re-run that process again.

  • As before close all active instances of Roon (i.e the current core machine and remote devices).

  • Enable your Roon core on another desktop or laptop computer and verify what the experience is like with your network based endpoints.


During both of the above troubleshooting exercises there should be no firewalls or antivirus application any devices. If you happen to be making use of a VPN I would bring this offline as well during this process


This is link to log (removed by support). Tests timing TBD. First please let me know if the logs show anything interesting. They didn’t last time. Neither did running without Norton on Android and Windows, which I’m not overly fond of doing.


Hi @Ron_Bierman1 ---- Thank you for the follow up. Confirming that the logs have been received.

I am going to be attaching them to your ticket for review by one our tech team members and as soon as they have shared their feedback with me I will be sure touch base again ASAP. Please do let me know what is observed when you try the proposed tests above.


Hi @Ron_Bierman1 ---- Thank you again for your patience here. I have been going through all of open “pre v1.5” tickets and had a chance to catch up with our tech who has been handling yours.

First, I wanted to touch base and check in to see if anything has changed in way of how your endpoints are performing after taking the updated to v1.5. Are your endpoints still not being seen by Roon? Does Windows still see them?

Secondly, based on the conversation we had, he mentioned that he is noticing numerous traces in your logs (i.e “disconnecting” / “re-connecting” warnings of devices) that would seem to indicate an issue occurring in your environment, which he believes in turn could be having influence on this behavior you are experiencing inside, and outside of Roon.

If things are still in the same state, I would still like to know the outcome of the proposed tests mentioned in my previous here.

Looking forward to your feedback!


When I tried to reply to your last email, my message bounced, so I’m repeating what I said here------

Thanks for checking, Eric. Enjoy your vacation.

Crossing fingers insufficient correction. Lost all devices again when I terminated core and then reopened. It worked again after I uninstalled everything and reloaded a second time.

Still works this morning on Node 2 connected by Ethernet, but I still haven’t checked receiver which hasn’t been on today and connects via lower band WiFi to router. I’m looking at ways to run Ethernet to receiver, which I’ve wanted to do independent of ROON anyway.

Disconnects may have begun yesterday when receiver came on line for TV and I was playing on Node 2? I’ll experiment that way, but probably not today.

BTW, I also had to uninstall and reinstall ROON phone app before it saw anything yesterday. This morning it doesn’t see Node, and I haven’t tried uninstalling and reloading app again.


Hi @Ron_Bierman1 ----- Thank you for follow up!

So just to make sure I am understanding your observations correctly. You started with a fresh install and right away all devices were discovered and accessible by Roon. However, after you had shut down the device hosting your core and then brought it back online you were faced the same issue as before and the audio zones were not present, correct?

I had a long meeting with our tech team yesterday about this issue you are experiencing and they have provide insight on how I should proceed forward with you here. However before we continue, I want to first check in on what the current state of your Roon setup is. This will give me an idea as to where to start in regard to the feedback provided by the team.


Even on a complete reinstall, I’m not seeing the NAD receiver. The Android app doesn’t see it either, even after I also reinstalled it and loaded the latest NAD update today.

Android app and ROON core on PC have both been seeing the Node 2 since the second set of reinstalls, a few days ago, so I’m able to listen to ROON and Tidal with the Node connected through hard-wired Ethernet to router via Onkyo receiver. (That receiver isn’t ROON-ready.)

Again, the difference is that the NAD receiver is on a lower-speed WiFi band from the same Netgear Nighthawk router. That band works fine for things like video streaming Netflix, usually even in Blu-ray.


Hi @Ron_Bierman1 — Thank you for the follow up, it’s good to hear from you!

Ok, so the NAD T758 V3 is the device that is not being seen by the application currently. I am assuming that T758 is being seen by the Bluesound application, is this correct? Furthermore, during your troubleshooting of this behavior with the T758 have you tried working with it on the stronger WiFi band?


Bluesound has always seen the T758. I regularly listen to “Favorite” radio stations via Bluesound. The Bluesound Android phone app also sees the receiver.

I tried to configure the receiver on the faster band when I first got it, but had to switch to the lower band when it wouldn’t operate on the higher. I haven’t tried it since, though I have done several T758 updates. There’s an LG TV a bit further from the router that operates on either band.

Maybe RAATServer (not a mellifluos acronym) is only checking one band when there are two on a router? We’re seeing connect-disconnects because it connects to the high band, doesn’t see the receiver, or anything else ROON-ready, and disconnects rather than trying the 2nd band?



I got the long message from Mike. Thanks for sort of escalating. I just paged through this string. It has been going on for quite a while, and I’m not up for further experiments. I’ve been using the Node 2 without problems for a few weeks. It is connected to an Onkyo receiver, which is on Ethernet to NetGear router sitting next to Dell PC with ROON core. The PC is Ethernet to same router. The Android ROON app on Samsung phone also sees the Node 2. I have been keeping current with updates on all devices, and have no idea which, if any, apparently produced stable connection to Node 2.

I haven’t seen the NAD T758 V3 receiver on the Android app or from core for months no matter what I updated or removed and reinstalled. On the other hand, I haven’t had any problems in a year using the receiver with Blusound or Spotify, nor with the Blusound and Spotify Android apps. Nor have I had any other problems on the network with the software on any of nine devices that depend on the router to access each other and the Internet. The high def TV furthest from the router doesn’t even experience visible feed delays with HD from Netflix via WiFi.

This may be some dumb thing I’m doing or not doing, a quirk in my configuration, or a bug in ROON networking software (the only software that experiences the problem and on both the latest operating system releases for Windows 10 and Android.) It’s disappointing that ROON logs haven’t narrowed down the problem source.

Other than continuing to do all updates for all related software and devices, I’m not going to spend any more time on this for a while.



TIDAL also works with anything on the network, and so does a stereo clock radio, the just added tenth network device.


A post was split to a new topic: NAD T758 V3 listed as “uncertified”