Can't find Upsampling controls

Just reinstalled my SonicTransporter i5. On my Roon account I can’t find the settings to change upsampling from 256 DSD to 128 DSD.
I changed it previously but can’t seem to find it now.

Thanks Brad

Click on the speaker icon and the then select DSP. Now click Sample Rate Conversion. Change DSD Sample Rate, then apply changes.

Hi Martin, I had tried that but the is nothing I can change relating to a sampling rate. I am guessing there is some other setting that is not allowing me to do this.
Any other ideas?

Hi Brad,

What about Device Setup, then Show Advanced and select a Max Sample Rate (DSD) to DSD128.

Cheers, Greg

Go to Device Setup, Advanced and change Max Sample Rate (DSD)

This is what I get in advanced settings 192 max only. No DSD.

Do you have Exclusive Mode enabled?

I don’t know Martin. Where is that located?

Go to Device Setup as before. You’ll see two switches at the top of the settings screen: Private zone and Exclusive Mode. Make sure Exclusive Mode is on, i.e. Yes.

I don’t see that option on the screen unless I am at the wrong screen.

Okay, let’s step back a moment. What device is the end point? Is it a Cyrus Stream X?

Playback Designs MPS-5 the Stream X is the interface for the DAC within the MPS-5.

I just reinstalled my laptop I am replacing with the Sonic Transporter and ultraRendu.
All of the settings I need in Roon to control upsampling and filtering are right there where they should be. The MPS-5 DAC section shows DSD 2x just as i set it for.

With the ST and uR none of the options for these settings exists and my DAC and X-Stream read DSD 4x. The iPad I control both the laptop or ST shows music playing but it only plays through the laptop when that is used in the system. I only have one connected at a time.
I don’t know if there is something wrong with the download of Roon in the SonicTransporter.
The remote download in the iPad works fine so it is not that.

Hello @Brad_Rockwood,

In Device Setup, what is the “DSD Playback Strategy” set to? Is the option for “Native” shown in the “DSD Playback Strategy” menu?

According to your screenshot, the DAC is limited to PCM 192kHz playback which will limit the DAC to a maximum of DSD64 via DSD over PCM (DoP).

There is a known issue with Playback Designs DACs that affects Native DSD detection on Linux based USB hosts. We’re working with Playback Designs to get this resolved for RoonOS based products.

If the “Native” option is not shown in the Device Setup “DSD Playback Options” menu, I can reach out to Sonore and Sonic Orbiter to see if something can be done to get this resolved.


The DAC will do 384kHz I don’t know why it only shows 192kHz. On the laptop I am replacing, when I put it in the system it shows 384kHz and 256mHz.

I used this SonicTransporter and ultraRendu a week ago with Roon. I played Qobuz and limited files from my server music. There were no issues and it sounded great.
At that time when I set it up, all of the proper screens showed up and I could play DSD x2 from both. DSD 4x was a problem as the i5 processor didn’t handle it well.

I received help here to find my complete NAS files and with the help finally was successful.
About 2 minutes to accessing the files the SonicTransporter died.

I sent it back to Andrew and he repaired it and returned it to me. Now Roon doesn’t seem to have the settings available.

Any help you can offer John would be great. I would prefer to not use a standard computer going forward but I’m not sure SonicTransport is going to be the answer for me.

Thanks, Brad

No I don’t have an option for Native or any settings on that page. The page is just not available.

I spoke with Andrew at SGC yesterday and he said there were the proper drivers specifically for PlayBack Designs.
He did a remote access in last night and adjusted settings that I had no idea about.
It played music last night at whatever sampling rate I wanted.
I had no time to listen other than to know it works. I’m going to spend my afternoon listening today.
Thanks to Andrew and others here for the help.

1 Like