Cant get into roon configure core [Solved: Only applicable to RoonOS]

Core Machine

Lenovo thinkcenter M920
Intel(R) Core™ i7-6700T CPU @ 2.80GHz 2.81 GHz
Windows 10 pro
64-bit operating system, x64-based processor
16gb RAM

Network Details
Intel i7 NUC (roon server widows 64)
Synology 920+ NAS (music storage 674GB / 88,000 files)
Router Asus ZenWifi AX

Audio Devices

Laptop / wifi
Ipads / Wifi
Denon avr / ethernet
Google pixel 2xl mobile phone / wifi
Intel Nuc / ethernet
ifi zenDac / USB
2 chromecast devices / wifi

Library Size

Library 674GB / 88,000 files

Description of Issue

I can not get into any type of core settings either by clicking on configure roon core in the setting menu or via a web browser. so i am assuming i am doing something wrong.

Generally eveything seems to be working OK on my local network but i am trying to extend my network with a VPN and i feel this might be same reason i cant see core. I understand roon does not officially support any VPN’ing but i still cant access core setup and this has been since day one.

I think that button is only for dedicated Roon os cores, Nuc running ROCK or Nucleus.


I thought that the Roon server installation I did was a roon core installation.

So how would I configure roon core?

You configure Roon using the settings, the configure Roon OS button is more like for the hardware side of things. As there is no OS outside of Roon it’s for the basic settings of the NUC/Nucleus hardware. Hope I’m making sense.

It’s like the settings in Windows 10, once you set them it’s done, but they’re not part of an app or program you are running.

That setting says “Configure Roon OS Core”. If you’ve not got a Roon appliance running Roon OS in your home network (e.g. a Nucleus), then pressing that button will just make Roon look forever in your home network for a device that does not exist…

If one does exist then you will see what the IP address is…

And if you click on the IP address, your web browser will open the Web Administration page, where Roon OS can be configured…

Thx all, understood.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.