Can't get my NAS connecting to Roon

Roon Core Machine

Core: Silent Angel Rhein Z1
Remote: MacBook Pro M1-2020

Networking Gear & Setup Details

Synology DS218+

Connected Audio Devices

Auralic Altair G1.

Number of Tracks in Library

Description of Issue

Roon fails to connect Roon to the NAS, keep getting error message (see image)

Can someone help me with the correct NAS settings?

Is your Core running on the MacBook? If so, can you connect to the NAS in Finder, and share the path that works. Also, you may want to change hostname to IP address in Roon.

No, is running on the Silent Angel Rhein Z1

Okay, try using NAS IP address.

I’ve tried that, but same result: unexpected error

You have a space on the file path. You can’t have that. Either remove the folder from the URI or replace the space with \ .

You mean the space between Muziekbibliotheek en Theo?

I get invalid network path

Did have the same problem until I changed to:


But I did leave the “workgroup” blank.

I have a QNAP NAS HS-264-8G

Yes. If you omit the share name, you should see the share list and be able to browse to the folder. If not, try escaping the space as shown, or change the share name, so it does not include a space. You could also try using quotes around “Muziekbibliotheek Theo”, but that may not work.

As mentioned earlier, use the IP address, and remove the space character. As @Torben_Rick says, the workgroup isn’t necessary.

Thanks Torben and Martin for your help.
It works!!
I’ve changed “Muziekbibliotheek Theo” in “Muziekbibliotheek” and I’ve used the IP address.
Thanks again!


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.