Can't get Roon Arc to work on my ROCK

Roon Core Machine

Linux, ROCK Version 1.0 (build 254) production, Nuc10i3FNHN, 256GB SSD, 8GB Ram

Networking Gear & Setup Details

Linksys Switch connected to Eero Pro 6 Router
Cat6 cable connecting NUC to Switch

Connected Audio Devices

Devialet 400 Expert

Number of Tracks in Library


Description of Issue

Getting the following error when setting up Roon Arc

“connectivity”: {“status”:“NetworkError”,“status_code”:404,“error”:“”},
“external_ip”: {“actual_external_ip”:“”,“router_external_ip”:“”},
“natpmp_autoconfig”: {“status”:“NotFound”},
“upnp_autoconfig”: {“server_ip”:“”,“found_upnp”:true}

I am currently forwarding as instructed to 55000 and still getting this error.

Welcome to the Roon Community.

What is your Roon Server version.

Mine is 2.0 (1148)

Hi @Ethan_Bloch,

Welcome to the Roon community. I will do my best to help you so you can listen to your music on the go.

When i look at the error message, UPnP is found but the automatic configuration hasn’t do the job. I think you need to make a manual port forwarding on the Eero Pro 6 router.

Open the Roon App and go to Settings —> Roon Arc. Write down the ip address and the port number shown there.

Take a look at below video and i hope you’re able to create the port forwarding.

Hope it helps.

Kind regards,


Hi @Maarten_Duits,

its difficult to follow all the different port configurations, are you able please to list them all in a reply?

Many thanks in advance,


I changed the manual report I was forwarding too and now all is good! Thanks for the feedback and responses :pray:

Hi @Ethan_Bloch

I have my Eero 6 pro setup the way you had it forwarding to 55000, so what do you mean about changing the manual report? Many thanks,


I suspect he meant to write “manual port”…

a manual port still does not work but this @Ethan_Bloch issue is the closest I have come on the Roon community forum to finding a fix for my issue. @Ethan_Bloch what port or ports did you implement?

Thank you!!!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.