Can't get roon remote app to connect

Core Machine (Operating system/System info/Roon build number)
Lenovo Flex 14 PC on windows 10. Firewalls (Bitdefender and Windows) both turned off.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)
Running on WI-fi connection through UBEE router (model 32c1). The endpoint is Raspberry PI running current version of Volumino.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Description Of Issue
The core finds Volumino and connects to it and I can control the music from the core. Also, the Volumino remote app on iPhone will connect and correctly control the PI over WiFi.

The remote which won’t connect is Apple iPhone XR running iOS 14.2. I also tried an iPAD with no luck. I have deleted the app and reloaded it.

I have tried all the steps outlined article “Why can’t Roon remote connect”.

Everything seems to work except for the remote control app. It says Waiting for Remote Core, etc.

You’re not by any chance using a VPN, are you? That can sometimes be the cause of things like this - where the two (or more) devices appear to be on different networks.

Not using VPN

Hi @Dale_Snyder,

Does Roon have Local Network permissions as outlined here:

I checked in settings and Local Networks access is turned on. I tried turning it off and back on but nothing changed.

Hi @Dale_Snyder,

Are you able to get any Roon remotes connected (such as other PC remotes), or do those not show up as well?

I also would check to see if you are connected to your network via a Private network, not a Public one, see this guide for more information.

I added Roon to my wife’s Mac but it couldn’t connect as a remote. It is on same network as the core. Note - after updating to private network setting, it now connects.

I checked my network settings and it was setup as public, which I changed to private. Cycled power on router and pc. Still can’t connect on iPhone, but the Mac can now connect.

1 Like

Hi @Dale_Snyder,

Having the Mac now connecting is a good sign that we’re progressing in the right direction. Regarding the iPhone, is it connected to the same network/router as the Core?

If you click on the “Help” button that appears, are you able to type in the IP of the Core and manually connect?

No, typing in the IP address of the PC running the core does not work. Yes the iPhone is on same network as the router and core. Also, when I went back to the Mac tonight it wouldn’t connect. Not sure what that’s about. We were gone all afternoon and nothing in the setup was changed.

I have noticed with other WiFi devices ( printers) that when they go to sleep the only way to get the network to find them again is to cycle printer power. They are supposed to wake up when you attempt to print. I suspect this is a router setting issue. I wonder if the router is blocking the Roon remote request somehow. These devices have been asleep all day. I don’t know if this helps but I thought I should mention it - I guess I suspect the router is the issue.

1 Like

Hi @Dale_Snyder,

Thanks for those additional details, yes this does sound like an issue with the router.

I would check to see if you have IGMP Snooping / IGMP Proxying settings on the router config and try to toggle those, it sounds like your mutlicast protocol is not operating properly on that router.

Or for an even better solution long-term, you can use a different consumer-grade router and place the current router into Bridge Mode so it acts just as a modem.

I couldn’t find any IGMP settings in my router, so I am right back where I started. Please clarify your comment about getting a commercial-grade router - why would that help? I am willing to spend the money and time if I’m not pretty sure it will solve my issues. Otherwise I can get Geek Squad out here to try to get current router working.

Hi @Dale_Snyder,

By consumer-grade router, I meant one not provided by your ISP. There are plenty of choices of modern router brands - ASUS / TP-Link / Netgear / Orbi to name a few, and typically we have found that their overall stability with Roon is much better than ISP-provided gear, as Roon requires sufficient bandwidth and functioning protocols (multicast) to work. Our Networking Best Practices Guide also provides more info on this.

You can ask them, but it may not help resolve the issue if the router itself does a bad job of passing traffic on the network, and with your printers also experiencing similar behavior, the router is most likely the cause.

One other test that we can perform here to be thorough, you can try to use the Macbook as the Roon Core. If the issues occur from there as well, then that further suggests the router is problematic. If the connection issues don’t occur when the Mabook is the Core, then we can investigate the original core further. To switch cores:

  • Open Roon on the other PC you wish to try as the Core
  • Roon Settings -> General
  • Disconnect
  • On the “Choose your Core” screen, press “Use this PC”
  • If asked to Unauthorize, you can go ahead and do so. You are limited to one active Roon Core at a time but you are free to switch between them as often as you’d like.
  • Verify if the same behavior occurs on the different PC