Can't get Roon to detect a Roon Ready ultraRendu device

Roon Core Machine

Roon ROCK (Intel NUC from reference list)

Networking Gear & Setup Details

Wired Ethernet

Connected Audio Devices

A number of Roon clients, one RoonBridge device and an opticalRendu

Number of Tracks in Library


Description of Issue

I have two devices (ultraRendu and opticalRendu), they are both on the same network and detected successfully with the sonicorbiter management console, they are connected to two separate hifi racks…

While sonicorbiter management console detected both devices, and I have set both to RoonReady mode, only one of these is detected by Roon Audio settings.

Fill in the network equipment details so Support have the information they need.

I have an ASUS ROG GT-AC5300 router, all wired network, Gigabit network with Cat-6 cables, one subnet, nothing fancy… everything works fine…

Have you ever seen the device in roon or is it new?

I rebooted a couple of times and now it is detected… Looks like everything is running fine now…

Another update, the problem resurfaced and then I changed the USB cable I am using to connect the Rendu to my DAC, and it looks like this was the cause of the problem, a faulty USB cable… Originally, I used the brand-new cable supplied with the DAC, but it looks like it is faulty…

I was not aware that Roon will not detect a RoonReady device if the USB cable is not connected to a DAC, I was troubleshooting power and ethernet connectivity, but it looks like USB is the cause.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.