Can't get Static or reserved IP address for NAD M50.2 for use with Roon

This is not the first time that I have brought this issue to the Roon community for help I thought I has this problem solved before but not any longer. No matter how hard I have tried, even with the help of computer technicians, I am not been able to get my NAD M50.2 server set, using my ASUS router, with a static or reserved IP address, for use with Roon software. I have been going in circles between NAD, ASUS, Roon & computer technicians, all to no avail. Attached is a screen shot of e-mail communication I had with NAD’s manager about this issue this morning and he said that I should go to the Roon community about it. I was able to set up my Vortexbox server with a static address so why can’t I set up my NAD M50.2 server with one?

Is there anyone out there that can help me to establish a static IP address or reservation for my NAD M502 so that I can use Roon to access the music on it without having to keep reprogramming a new IP storage address for the NAD M 50.2 into Roon each time the IP address changes?

Which ASUS router do you have? You should be able to assign a static IP from your router to the NAD M50.2 based on its Mac address from within the router’s web interface. I’m a little rusty on ASUS routers, (been a while since I had one) but from memory this was a fairly straight forward process.

Edit: also from my ageing memory - set the static IP for the device according to its Mac address within the router, but leave the device’s IP config set to DHCP and allow the router to assign the static IP over DHCP. Don’t set the device config to a static IP - none of my Asus routers seemed to like this and it resulted in connectivity issues.

Hi Greg
Graeme is correct you should be able to do this on the router, but if that doesn’t work, does the NAD have an App or web interface where you can go in and give it an IP address outside of the DHCP range, as that would also solve your issue.

Regards

Mike

His equipment might not let him set a static IP.

It’s possible, but I’ve not found a piece of kit that I couldn’t assign a static IP address to so far…

From my experience of ASUS routers (3 or 4 different models), the web interface was the same on each and it was fairly straight forward to assign a static IP to a device based on its MAC address.

Rugby that’s why I asked the question as he has not stated above if that is an option or if he has tried it

Regards

Mike

As has been mentioned the solution is configuring a static IP on your router, searching for “set static IP Asus model” replacing model with the model you have should lead to written and or video guides explaining just that.

It’s a little cheeky of NAD just to point a finger at Roon. That said it would be within the realm of possibility to map end points via MAC addresses instead of IP.

Hi @Greg_Johnson,

As other users have mentioned here, I would suggest you set up a Reserved IP Address in your router configuration, most modern routers should support this feature. If you are still having difficulties here, please let us know your exact router model, thanks!

My ASUS Router model is RT-AC66U Dual-band Gigabit Router 802.11ac Wireless-AC1750.

As mentioned previously 5 different technicians have attempted to establish a static IP address or a reservation and while it appears, initially, that they have done so, after a power outage or software update, it is apparent that the IP address is dynamic. That means that in order for Roon to be able access my NAD M50.2 server, I have to go to Roon and “reprogram” the storage address with the new IP address and wait for hours before Roon can re-scan and access all of my 108,000 stored songs.

Once again, I mention that I have not had this problem with my Vortexbox ripper/server, which has successfully been assigned a static IP address and does not suffer from the non-static IP address problem that the NAD M50.2 server suffers from. Why would it be that be I can establish a static IP address for the Vortexbox but not for the NAD M50.2? - would this be because of an inherent problem in the ASUS router, the Roon software, the Roon Nucleus+ server or in the NAD M50.2 server? I also have another NAS attached to the network that is not being used. One of the technicians I used suggested that there is something inherent in the NAD M50.2 that is preventing assignment of the static IP address but NAD has rejected that. Another technician suggested that I needed to contact NAD which I did but they said it sounded like a Roon problem.

to summarize my home network system, I have an ethernet home network set up with a Hitron Modem Model CGNM-2250) bridged to the ASUS router, connected to three ethernet switches. The first ethernet switch (Linksys SE4008) is connected to the modem and the router. That ethernet switch is in turn connected to a Linksys SE2008 ethernet switch which is in turn connected to an EtherGen (Uptone Audio) ethernet switch for cleaning up noise.

Is there anything else that you can suggest that I try to solve this non-static IP address problem?

It’s all right here at the bottom of the screen:

Any problems you are having manually assigning an IP address to your NAD fall squarely on Asus’ shoulders and no one else’s.

The NAD has no way of knowing it is being assigned the same IP address by the DHCP server. This has nothing to do with Roon.

1 Like

I would say “manually reserving an IP address”. Otherwise, you might get the idea you can set an IP on the NAD itself.

@Rugby

Look at the actual words used by Asus on the screen! You are manually assigning the address the DHCP server hands out to a particular MAC address.

Can you supply a screen shot ala SpeedRacer’s, showing the static IP config in your router.

Couple things come to mind,

  1. For some idiotic reason the NAD is using a dynamic MAC (no sane reason for this)
  2. The static IP/MAP mapping isn’t being saved correctly on your Asus
  3. An extension of 2, but your Asus is not actually doing DHCP (handing out Ips) and something else on the network is.
1 Like

You need to start tracking the Ethernet MAC address on the NAD and verify this is not changing. DHCP reservations are locked to the MAC address of the device. A “reservation” is a simple mapping of Ethernet MAC Address to IP Address and when the DHCP server (router) sees a DHCPDISCOVER from that MAC it will respond with that IP Address instead of one from the pool. Each “ethernet” PHY on the NAD will have its own MAC. This means Wifi and Wire will be two different MACs. Make sure you’re using only 1 network interface on the NAD and that the other one is disabled.

If the NAD is changing it’s MAC address then reservation on the DHCP server will fail as the mapping is no longer correct (and the NAD will get an address from the pool). If the NAD is changing the MAC then this should be considered a bug as it can cause other issues on your network.

The ASUS should have an ARP table that shows you the MAC Address to IP Address mapping. Once you have a reservation this entry should not change as the reserved IP Address will always map to the some MAC Address (of the NAD).

Couldn’t disagree more strongly.

Do not assign static addresses from within any device. This is what gets your router software confused.

Let DHCP in your router software assign addresses.

If you want to assign a specific address to a device, do so from with in the router software and use a ‘Reserved’ address, as suggested by @noris and @Speed_Racer.

When you assign a Reserve, make sure you are specifying the correct MAC.

Like you, I doubt this is happening.

1 Like

I think you misunderstood me, I was saying if the NAD was using a dynamic MAC that would explain this but its highly unlikely, which you are of the same opinion.

Ok, a NAD (or any device) can’t assign a dynamic address. The router software assigns a dynamic address and reassigns a new one when the current addresses’s lease runs out.

OTOH, a MAC is generated by a device’s firmware and as such is semi-permanent.

Greg,

When the power interrupted and the information was lost on the Router; was all Router setup information lost or just the NAD’s assignment?

If all setup was lost, then that could indicate a failure of the NVRAM on the router.

Daniel