Can't get Tidal to work with Roon

I have a Tidal account which I have accessed in settings=>services and logged into. I cannot play Tidal through Roon receiving the message “this track is currently not available from Tidal” and “too many failures, stopping playback”. Moreover, Tidal on Roon does not see my Tidal playlists. I have logged in and out of Tidal a number of times; I have rebuilt the Core and still the same messages.

System is a Mac Mini; QNAP NAS; ethernet connections between the two; Naim UnitiAtom end-point with wifi connection. I don’t have a problem with Roon playing to the end point with music on the NAS

Please help me to figure this out.

I should have added that I have tried Qobuz for the purposes of comparison and Roon works perfectly. Also, I noticed when setting up Qobuz I have a choice of streaming qualities whereas in Tidal I am told that no streaming options are available.

Hi @franstep2020,

Can you try to sign out of TIDAL, reboot your Core machine, and then sign back in?

I’ve also enabled diagnostics so we can take a closer look. Thanks!

Hello Dylan, I’ve done what you’ve suggested. There is no change and Tidal still does not work and after logging in does not allow any choice of streaming format. Quorbus still functions correctly. Thanks


Hello @franstep2020, I blanked out your email in that screenshot for your security. Also, in just a moment I’m going to send you a PM with next steps. Please take a look!

Hello nuwrly, Thanks for your other mail. I did what you requested and in process discovered that somehow my two Tidal accounts had become confused. I have fixed the problem and for the moment Roon is working as it should. It seems the problem was entirely mine. Apologies and again thank you.


A post was split to a new topic: Roon issues with TIDAL

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.