Can't install RoonServer(20210727) on DSM7, shows "installing" for an hour

I tried to install the RoonServer ( which is 100kb on DS920+ with DSM 7.0-41890. I am a new Roon user and I have never installed other version on my Synology NAS before. I followed the instructions and created a shared folder named “RoonServer”.

But when I came to the final step, the system couldn’t finish the intalling process, which shows “installing” for hours and no other hint. I can only stop this process by restarting the DS920+ system. After all I still can’t install the RoonServer sucusessfully.

Please notice me how to solve this problem, thank you.

The problem is solved. After 2 hours it finally shows.

I checked the permissions for the shared folder “music” and changed it to read&write for “Roon Server”.
But I think it is a little bit confusing by giving me the hint after two hours waiting. Anyway its done now. Thank you.

1 Like

The installer downloads the current version of Roon Server from the Roonlabs website during installation.
It seems the installation is stuck in the download process.
The installation routine has an option, to skip the download, if you provide the required file by manually downloading it from the Roonlabs website and place it in your database shared folder.

On the Roonlabs download page select Roon Server for “Linux x64”:

On the next page click the download link in the “Manual Install” section for “Roon Server (x64)”:

The downloaded file should be named “RoonServer_linuxx64.tar.bz2”.
Copy it onto the shared folder, that you want to use as Roon Server’s database.
(In your screenshot this was “RoonServer”)
If you look at that shared folder in FileStation, it should look like this:

Try to install Roon Server again with the beta spk and select “Offline installation” in the last installation step:

This time the installer won’t download the file from the Roonlabs website and use the file, you’ve copied to your RoonServer shared folder.

I hope this solves the installation issue.

1 Like