Can't log in on new computer [Resolved]

Just transferred my Time machine backup to a new iMac. Now I can’t log into Roon. I type the credentials then the logging in animation starts, but never gets past that. I have reinstalled Roon and restarted the computer a couple of times.

running 1.4(build 291)stable (64 bit)
Mac OS 10.13.2
iMac retina 5K 2017 with 16 GB 2400 DDR4
music is on external hard drive

Time machine does not play nicely with client server and database apps like roon. Use Roon backups. You might be forced to re set-up roon as the database will probably be messed up. This will mean removing roon and it’s specific folders in the library folders and reinstalling from scratch most likely.


Unfortunately, Time Machine generally does not work for a live Roon database.

If you are using Roon’s backup feature, Time Machine can backup the archive Roon creates, but if you are depending on Time Machine to backup Roon’s database, there’s a very good chance the database has been corrupted, and unfortunately this is one of the known symptoms

Can you clarify whether you were restoring a Roon Backup, or trying to use Time Machine directly? If it’s the latter, we can take a look, but in most cases there’s very little we can do once Time Machine has tampered with the database, unfortunately.

I was using automatic Roon backups. Do I need to find all Roon files and delete them and start over?

But there are backups within Time Machine, it looks like

Ok, that’s good news.

On the new computer, are you restoring the Roon backups? Are you following these steps?

Attempted to restore database and I got an error message.

“There was an issue restoring your database.”

Hi @Zoren ----- Thank you for touching base with us and sharing the observations made after having tried to restore your DB from a previously created backup. I am sorry to hear of the continued troubles.

Moving forward, I would like to kindly ask you to perform the following (in this order):

#1 - Log gathering:

  • I would like to have our techs review your Roon logs from the the DB that is currently in place to see if we are able to determine what may have gone wrong. With this in mind, please use the instructions found here to send us a set of your “Roon” logs.

#2 - Test with a fresh install:

  • While our team is conducting their investigation, I would like to ensure that you have access to the application. So I would like to propose using a fresh DB which can be achieved by performing the following:

    • Locate your Roon database according to these instructions
    • Rename the entire Roon folder to roon_old
    • Relaunch Roon, sign in, and configure a new install
    • Let us know if you see this database error again


I had a SMH moment as I was going to bed last night.

I still have the old computer. So I made a backup on the USB drive that my music is on from the old computer and installed on the new.

Problem solved.

Thanks for the help. Your support is excellent and very much appreciated.

1 Like

Thanks for the update @Zoren, very pleased to hear things are now working as expected. Excellent work :clap::thumbsup:

Happy listening!