Can't log in Tidal while in Roon

I’ve been using Roon to play music from Tidal without any problems for almost a year. Today, my playlists say “Unavailable” next to tracks that are from Tidal. When I go to the “Services” tab in Settings, it indicates that Tidal is not configured and that I’m not logged into Tidal. When I try to log in to Tidal in the Services tab, it says “bad user name or password.” But I can log into Tidal on the Tidal app using the same user name and password without any problems.
I saw the suggestion in a similar post that I should sync Tidal in the Services tab, but since I can’t log into Tidal in the Roon app, I don’t have an Edit button or a “Sync Library Now” option next to Tidal.

Thanks for reaching out, @David_Babbe!

So we can better assist you, please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Please also verify the following:

  • Have you tried rebooting your Core machine?
  • What kind of TIDAL account do you have? What region is it for?
  • You mentioned you were able to login to the TIDAL app. Were you able to do this from the same machine as your Core?
  • Have you confirmed that your TIDAL account is still active? In the past we have seen some cases where an account was unexpectedly inactive, and while you can still log in to TIDAL, the subscription may not be active for Roon to use.


Dylan: Thanks for the very prompt response.
Here is the information about my setup:
Roon Version 1.5, Build 339 (stable) 64 bit
OSX Ver. 10.13.6
MacMini 8 gb of RAM
Music stored on external HD connected via USB
32,000 tracks
My Mac Mini is connected to my network via an ethernet switch. My iMac (which I use as a Roon control) is also connected to my network via an ethernet switch. I also use an iPad and iPhone as Roon controls – they are connected to my network via WiFi.

I have tried rebooting my Core machine
I have a Tidal Hi-Fi account; California
I use my Core only for Roon; I access Tidal through an iMac, iPad and iPhone (and can log onto Tidal using the Tidal app on all of those devices)
I believe my Tidal account is still active – I can access songs from Tidal using the Tidal app on all of my devices. I have also confirmed that I had the appropriate credit card for my Tidal account. I also updated my password for Tidal.

Thanks again for your help.

Dylan: Not sure what happened, but I can now log into Tidal through Roon. Maybe it had something to do with Tidal’s network problems?
Thanks again for your prompt follow-up.

1 Like