Can't log in to Roon

New problem. Running lastest version of Roon 1.2 (build 142) on a dedicated MacMini, 2.4 Ghz Duo, 8GB ram, 10.8.5

Will not recognize my login on Roon server. have tried resetting password without luck.

No other changes on computer.

Are you accessing the new Mac mini directly or over a some kind of vnc connection?
Just to rule that out: I realized some issues with special characters and localization problems over vnc…
(especially when connected from an iOS device over vnc to a mac computer. :slight_smile: )

If that is not the case, I would check if there are any other unique network settings that might prevent full internet access (firewall?).

I am using screen sharing on home network to access the mini as it is headless. But it has always been accessed that way with Roon for more than 6 months. No special characters in login or password. No changes to house network or firewall.

Hooked up an usb keyboard and directly typed in the info, still getting hung up on “logging in”.

Weirdly enough, Roon is installed on our main iMac also. Only use it their as a remote. Was able to bypass normal library connection and login.

Hmm. Weird. Some things that came to my mind:

  • Have you tried to start and login to Roon on the MacMini with a fresh library?
  • Has the MacMini just 1 connection (Ethernet or Wifi) to the network and is not connected by parallel connections (Ethernet+Wifi)?
  • Does the Mac mini have the same DNS entries in the network settings like the previous server machine?
  • Are all other network settings similar to the previous machine’s network settings?
  • Is the MacMini the only active RoonServer at that moment when you try to login?
  • if possible: try to boot the Mac mini from the system disk (via target disk mode) of the previous machine (in case it is a mac) and check if the problem occurs as well.

Not quite an eloquent fix, but I just deleted and reinstalled. No working. Something must have corrupted the Roon library.

Just for your info:
Did try with fresh library on remote and worked
Only connected via wifi. Doubt network issue. Cisco ASA hardwired to 3 Cisco switches hardwired to WAP.
No change to DNS
No change to network settings
MacMini is the only RoonServer (in dedicated audio room with USB DAC attached, thus the headless setup.

Sorry, is your issue fixed? As you were writing about a fix, I am unsure if you meant to write “Now working” instead of “No working.” :slight_smile:

You had a fresh library on your MacMini and could login with a remote, correct?
I’d take a look at the privileges of the Roon(Server) and RAATServer folder in the user library.

I don’t know anything about OS X, but this article has some interesting comments about the usefulness of permissions verification and repair:

Quit Roon(Server) on your MacMini.
Try to open your user’s library folder (Click in the Finder on “Go” in the menubar and select, while holding the “alt” key, “Library”. You won’t see this entry if the “alt” key is not pressed!).

Navigate to the Roon(Server) folder select it and press “cmd”+“i”. An info window will pop up:

In the “Sharing & Permissions” section, check who can read and write to that folder. Normally this would be (like in the screenshot) your user with Read and Write privileges and stuff + everyone with read only privileges.
If this is not the case, adjust it with the + and - buttons to fit. You need to press the lock button in the right corner before you can make any changes. If you made changes click on the gear icon and click on “Apply to enclosed items”.
Do the same for the RAATServer folder.

It could very likely be that the permissions are set to your old user of the old machine. But that is just an assumption…

A post was split to a new topic: Problems Loading Billing Page