Can't log in to Tidal from Roon

Anyone having this problem? Tidal works fine through the internet or through its own app. I get the pink login failed box from Roon. I tried on the iPad, on the mini which is running the core and on the remote.

Running normal here. Have you tried restarting your core?

Thank you - that worked! Good to note for the future.

1 Like

Got a message that my Tidal log in failed. Restarted Roon, no luck. Restarted my MBP, on which Roon resides, no luck. Tidal runs in my browser, the iOS app works no problem. Was going to delete my Roon cache as suggested above, but decided to click ‘edit’ in the login message instead of ‘retry’. My user name was there, but the password field was blank. Put in my password, back up and running. Anyone else seen this behavior?


Yes. Your solution is the one that worked for me earlier. There’s another thread on here. Had to re-enter my password and all is well. Except for, you know, the interruptions.

Yup - exactly the same here. Password field got cleared, and I had to resubmit to log on successfully.

Same issue as reported here. Looks like Tidal did something at their end that broke the Roon login.

Same deal here: Roon just forgot my Tidal password and I had to re-enter it.