Can't Log In to Tidal via Nucleus

I cannot log in to Tidal with Nucleus as the Core.

If I change the Core to my Mac, I can log in to Tidal successfully. I can log in directly via the Tidal app on my Mac. The only failure point is when Nucleus is the Core.

I have logged out/in every application. I have re-booted every element in the system: router, modem, Nucleus, Roon app, Tidal app. I tried being logged in to the Tidal app vs. being logged out of Tidal, all possible permutations. Music plays normally in every configuration except Nucleus Core --> Tidal login.

Every attempt to log in to Tidal with Nucleus as the Core gives the same response (no variation): Network error: Please check your connection.

It is clear to me that Tidal is not the problem. There are no problems with any configuration, except logging in to Tidal via Nucleus as the Core.

Any ideas?

Just looping in the main support alias. @support

Hi @Carey_Smith,

Has this worked previously, or have you never been able to log in to TIDAL via the Nucleus Core?

So we can better assist you, please provide the following:

  • Network details including what networking hardware is in use and how the devices are connected
    • Is there any difference in how the Mac is connected compared to the Nucleus Core?
  • A screenshot of the Nucleus Web Administration Interface

Yes, I could get to Tidal from the Nucleus before. The only recent change on my end was changing the ethernet connection of the Nucleus from the Internet Provider’s router (Arris) to the ORBI mesh network, which is plugged in to the Arris router.

However, when I make my Mac the Core, the login to Tidal from Roon is successful, whether the Mac is connected via ethernet to the Arris router or the ORBI router, or via wi-fi over either router.

All devices – routers, Nucleus, Mac – have been repeatedly cycled on/off, unplugged/replugged, re-booted, connections re-seated, etc. etc.

The Nucleus is normally in another room from the Mac, connected to the ORBI router (satellite node) via ethernet and the ORBI connected via wi-fi to the Arris router; the Mac is connected to the ORBI router via wi-fi. For this troubleshooting effort I also moved the Nucleus next to the Mac and connected the Nucleus to the ORBI primary node.

Screenshot of the Nucleus Web Admin Interface:


System Status

Serial #94C691A2E380

Operating System



Version 1.0 (build 174) stable

Running 12 minutes, 46 seconds.

Roon Labs Software


Version 1.0 (build 9) stable.

Running 12 minutes, 40 seconds.

Roon Server Software

RestartToggle Dropdown


Version 1.6 (build 416) stable

Running 12 minutes, 37 seconds.

Roon Database & Settings



91% of 55 GB available.

Internal Music Storage



2000GB, WDC WDS200T2B0A- 42% of 1848 GB available.


Hi @Carey_Smith,

Thanks for the info here. Just to verify, if you connect the Nucleus back directly to the Arris router, does that then work for you?

Can you set the router to use Google DNS? Is there any change after doing so?

In response to your question, I had already tried connecting the Nucleus directly to the Arris router for the Tidal login, without success.

Today, I just now opened Roon to try again to log in to Tidal (hope springs eternal), and found that Roon was connected to Tidal. < !!! > I did not log in manually.

I did not make any changes or other efforts since my last communication, yesterday, so I assume you guys did something from your end. Would you mind telling me what it was, so I can understand the source of the problem?

Thank you.

Hi @Carey_Smith,

I’m glad to hear that things are working for you now! On our end we didn’t make any changes — It sounds like there may have been a networking issue preventing your Nucleus from being able to connect to TIDAL to login. If you see this behavior return please let us know and we’ll take a closer look.


1 Like