Can't log in to Tidal

That means exactly that… the login failed.

Either it was network or authentication or something else unknown. TIDAL didn’t work. You can try retry or check your login/password.

Can you login on their website?

on sooloos there was a error in the code… if the password contained a “#” it did not work. might that be the problem? a to complex password?

As I said, only a problem with Roon. I can connect to TIDAL fine with browser, iPhone and Auralic Aries. The error box gives me a choice to either retry or edit. “Retry” does not work and, if I choose “Edit”, it shows my correct username (email address) and gives me the option to “Logout”. It also says “STATUS: Failed to reconnect. Please retry later, or edit your account information.” It also has a blue “Login” button. If I choose that, it says “There was an unexpected error: UnexpectedError.” My password has no unusual characters.

Is there phone support as doing this via messages is a pain? Thanks.

Hi @Regnad – I’m going to send you a private message to get some more information about your issue.

We really appreciate your patience here!

Hi Mike,

I got delivery errors responding to your emails. My tidal login is my email address and I just sent the ID info. Thanks.

Thanks for your help troubleshooting this @Regnad! Glad you’re up and running.

For the benefit of others, if you’re having trouble logging into TIDAL when using Roon on OSX, you may want to start by deleting the cache located here:

/Users/[your user name]/Library/Roon/Cache

Once you’ve deleted the cache, restart Roon and try logging in again. Let us know how it goes folks, and sorry for the inconvenience – looking into the cause of this now.


Okay, I have followed the instructions to delete the cache, and now I can restart Roon. The side effect is that I have lost the playlist I created yesterday in Roon. Yesterday, I have tidy up my itunes playlist and deleted the unwanted ones, and they reappears after the cache was deleted, with it, a random playlist baring the old playlist name with most of the old playlist songs, but with a couple of random songs added to it.

So, I disconnected iTunes, and reconnect it. Most of the playlists are fixed. However, there are a duplicated playlist and that random playlist is still there.

FYI, the Roon probably started when the computer didn’t restart from sleep, and I have to restart.

PS - some tidal tracks that was added yesterday are gone. As of most of the history from last night.


I have the same problem. I am unable to login to Tidal through ROON, although I can do this from my internet browser. This means that there is no problem with my Tidal account.

I tried the solution you mention above, but it does not work.

It is very strange because the Tidal connection was working very well yesterday!


What error are you getting? You said it was working yesterday, it was working in Roon yesterday?

I’m getting TIDAL: tidal_account_error even though I could sign in successfully to Tidal.

I cannot get signed into my Tidal account with Roon. I can get singed into Tidal direct, but when using the Roon interface with the same username and password I get this error message.

“There was an unexpected error: UnexpectedError”

This happened when I moved my main roon account to a beach house computer and then tried to move it back to my main house account. I deauthorized the beach account when I did this.

Any ideas?



1 Like

Hi @AlaBill – can you try what I mentioned above and be careful to delete anything beyond the Cache directory.

Let us know if you’re still having issues and we’ll take a deeper look. Thanks!

Hi Mike,

Same thing as before.

“There was an unexpected error:Unexpected Error”

I did exactly as you suggested above, I deleted everything in the Roon Cache file, emptied the trash, and restarted Roon. Same result.

What next?


Hey @AlaBill – you’ve tried logging into the TIDAL website or desktop app right? Just want to confirm this issue is only occurring in Roon before we dig deeper.

I know you mentioned this above, but just double-checking, then we can follow up and get some more information.



Working properly on Tidal website. I can play that, but I just hate their interface.



I finally trashed the application and all the associated files and downloaded the Roon program again. Working fine now.


Having a similar problem here- yet more pervasive. When searching Tidal and/or adding from
the ROON animated logo moves for a minute or so, then an error message “error loading page-please check your network connection”

  1. Network is fine
  2. Able to log in to Tidal via its interface- so problem not with Tidal- just ROON/Tidal interface
  3. If I close out ROON and reopen- works for one or too searches/additions from Tidal- then error repeats
  4. When gets “stuck”- ROON will not play tracks- can’t get to “Overview” etc…

Deleted and reinstalled. Now missing over 275 albums/ 5000 tracks saved from Tidal over the past week.
All of those seem to be present in Tidal app, just not integrated into ROON.
ROON still inoperative per earlier post.
Under settings/services/ Tidal sync time is blank. When try to force sync (pressing circle in upper left)
app again stalls and eventually return with “error loading page”…

Anyone else having Tidal login problems currently?
My Roon account simply won’t let me login, but I can login using the same credentials via Tisal web app…

Must be a problem with Roon…and my typing!

Yep, same here, dropped my connection to Tidal while listening to a non-Tidal file in Roon. Can log in to the website and the iOS app just fine. I quit and restarted Roon and now I appear to be back in. Hmmmm…