Can't log into TIDAL in 1.7

I’m having a problem logging onto Tidal since the update. Although I know that the passwords are correct, it’s telling me that they’re ‘bad’. I’ve logged onto Tidal outside of Roon without issue. Qobuz is working perfectly. I’m also using an Innuos Zen 3 with Chord Hugo TT2. I would be grateful for help in re-setting up the Tidal facility.

Hi @Sonia_Lambert,

Can you try to log into the TIDAL web player ( from a PC/Phone and let me know if the same login works there? After that I would check to make sure that you are using the same credentials for Roon.

Yes, I have tried logging onto a mobile and iPad, all with the same login information. All other Tidal facilities work except for Roon. The message I get when I try to login to Roon is ‘bad user name or password’, but I know that they’re correct.

Have you rebooted the roon server?

That’s worked, thank you. The Roon database needed updating, and once completed I was able to log onto Tidal. Thanks again.

1 Like

Glad to hear that rebooting the server helped @Sonia_Lambert!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.