Can't login on ROCK

@noris I believe I have exactly the same issue or a very similar issue at least. I logged out of my account because I kept getting unauthorized errors when accessing Tidal content. So I decided to wipe everything clean and reinstall everything from scratch. Everything was installed fine and I could access the server from the web interface. However, I am unable to log in to Roon with my account. Looking at the log file, it seems that all other API calls are being made and processed fine, but the login calls to fail for some reason:

Now, I can restore an old backup and run the ROCK fine, until I log off my Roon account. Then I am, again, unable to log in. It seems that the way you guys handle the login API call results in errors for me at least. Now, I can call the same API from Postman using my username and password and I get the result I expect from it including the userid and token. Any idea what could be happening here?

Thanks for your help with this.


As an experiment, I tried setting up a Windows PC as a Core and I was able to login fine there. The issue is just limited to ROCK it seems. And as I mentioned if I restore a backup, I can access ROCK and it works as expected except that frequently I get unauthorized errors when accessing Tidal content, and if I log out of my Roon account, I cannot log in. So based on what I have observed, there seems to be something failing with the authentication handling code in the ROCK itself.

Months and months ago, I was able to set up ROCK and log in to Roon just fine, but at some point in recent months, the issue started happening. I am assuming some sort of code change resulted in the issue, but that’s just my guess and I am just trying to give you more context from my experience.

Hi @Steve_Hong ,

How is the ROCK Web Interface configured, what DNS addresses are you using, the default or a specific one like Cloudflare DNS, Quad9 or Google DNS? Do you have multiple interfaces active on the ROCK like Ethernet + WiFi?

This is what I have:

. No Wifi. Just LAN connection.

I have an update on my issue. Last Saturday, I was looking at my Orbi router settings to see if everything was set up correctly and ended up enabling IPv6 support for reasons not related to my ROCK issue. Immediately after that, I tried logging in to Roon, and I was able to. Just for a test, a few days later, I tried logging off and back in, and it worked fine. I can’t establish what I did with the router as the cause of the fix definitively, but maybe just fiddling with the router and resetting and rebooting it fixed the issue. @noris do you think that rebooting the router was the fix I needed? I am still uneasy about this issue because I don’t know what the issue was and how it was fixed. If the problem returns, I will report it here, but for now, everything seems to be working fine for me.

Hi @Steve_Hong ,

Thanks for letting us know that enabling IPV6 and rebooting the router helped with the issue! Have you still seeing the behavior re-occur since making those changes? If so, please let us know and we can take another look!

No issues. In fact, I just logged out for a test and was able to log back in. I don’t get the annoying “unauthorized” errors when accessing Tidal content as well. All good so far.

It seems that there was some sort of network-level issue that I was able to fix by messing with the router. There was another user reporting a similar issue before and he said he was able to work around the issue by connecting to mobile wifi instead of his router. That’s what prompted me to play with the router in the first place.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.