Cant login tidal, although login succesful

Roon core is an innuos zen mini mk3, latest version. Usb to pro-ject dac. Updated roon to latest version today. “Tidal login failed”. Go to settings, services, tidal account says “failed to login” press on edit,.if you have a tidal account log in now, did that, taken out of roon app. Taken to Enter email and password. Taken to page login successful. Roon + tidal, you have successfully connected your tidal account (with a big green tick). Return to roon if your browser (safari) doesn’t automatically take you. (Which it doesn’t). Return to roon app. Big pink warning triangle. TIDAL login failed. (Again and again etc). It’s like its stuck in a loop. The result of which I cannot get tidal. I have switched the core on and off, powered down on numerous occasions. Downloaded the roon app again on my ipad. Nothing doing. I can play radio stations, cd’s stored in my innuos but no tidal. I really don’t know what i can do more? I’m a new subscriber to roon, joined in January this year. But now i am regretting this decision. Support please resolve this problem, i need access to my tidal library which i am also paying for. Thank you.

2 posts were split to a new topic: TIDAL Login Issues (Windows 10)

A post was split to a new topic: Trouble with TIDAL login

2 posts were split to a new topic: I am unable to log into Tidal

A post was split to a new topic: There was an unexpected error, please check your account details. (MissingMethod)

A post was merged into an existing topic: Roon not connecting to server

Finally managed to get tidal login. I found that if i tried to login from the tidal tab on the left hand column, and not via the settings route further down it worked. Slowly it loaded all my files. If anyone else is still having similar trouble, i suggest you try this way.

Disappointed that nobody from technical roon labs support even acknowledged my post or tried to resolve it.

A post was split to a new topic: TIDAL login issues following build 528

Hi @Ian_Clarke,

Apologies for the difficulties you had logging in here, and glad to hear that you were able to resolve this behavior by manually logging into TIDAL again.

We have had a few reports regarding this behavior, and we are investigating what caused this with QA’s help.

In any case, logging into TIDAL should have been a one-time issue but if you experience any further issues, please do let us know.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.