Can't login to Roon anymore [Resolved - Update Bullguard]

Since I got back from holiday I can’t login anymore at Roon from the application on my PC.
I had some communication about it with customer service but in the end they couldn’t help me any further.

Inspecting the logfile of the unsuccesfull login, I this socket exception::
10/22 21:15:17 Warn: Broo Debug Web GUI failed to start: System.Net.Sockets.SocketException (0x80004005): Er is geprobeerd toegang te verkrijgen tot een socket op een volgens de toegangsmachtigingen niet toegestane manier
bij System.Net.Sockets.Socket.Listen(Int32 backlog)
bij Sooloos.Http.HttpServer._Start()
bij Cola.Server.Run(Boolean useeventloop, IPAddress addr, Int32 port)
bij Broo.BrooInspect…ctor(Engine engine)
In English translated: there was an attempt to get access to a socket in a way which is not allowed according to the access authorization rules.

My Roon Core is at my Windows 7 PC (64 bit)

The last succesfull login was at 9 october. That’s exactly the start date of
Roon membership 1 year ago. Is my membership implemented for 1 year instead of lifetime ?

I have screenshots and logfiles, if you’re interested.

@kevin think this might be yours mate.

Yes, I had email communication with Kevin about this problem. His advice was to get in touch with Support.

Hey @Ed_Versteeg — I appreciate you reaching out!

So we can better assist you, please describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Have you tried rebooting your Core machine since noticed this behavior occur? Do you have any antivirus or firewall enabled on the Core machine?


Hi Dylan, I appreciate to help me out of this.

Second part, is easiest to answer. Roon Core is installed on my PC. Each night I shut it down and each morning I start it up. But this time it was a bit different. The last log file with a succesfull login was at 9 october. After that I didn’t use Roon. From 13 until 18 october I was on holiday. At 19 october was my first unsuccesfull attempt to login. So there was an unusual gap of 10 days. I didn’t do it anything special, in terms reinstalls etc. on my PC or network.

Bullguard is installed as antivirus and firewall software.
Should I put it off for a while to see if it makes a difference ?

Network is hard describe for me as a non-technician. My PC is with an internet cable connected with my modem/router. The NAS with the music files is usb connected with the modem/router.
My PC is an endpoint for headphone listening in my study.
My main hifi system in the living room is the 2nd endpoint. The connection with the router is wired. I would have to investigate about the technology.

So far so good. Kevin has got some log files and screen shots. Maybe they will help.
If my answer if not clear enough, don’t hesitate to ask.

Hey @Ed_Versteeg,

We’ve recently had reports of other users with Bullguard who have been experiencing the same issue. Another user here reached out to Bullguard about this and they mentioned that this is a known issue that they are working on currently. I’d verify that Bullguard is fully up to date. If Bullguard is up to date and it’s still not working you can disable the firewall through Bullguard you should be able to login without issue.


I was about to disable the Bullguard firewall. Before that I did a check to be sure the login problem still was there. And you’ll guess what ? Everything was doing fine like before. No socket exception anymore in the log file.
Was opening the Bullguard application, bringing the application up to date, the key to the solution ? Usually that’s not necessary.
Anyhow it’s solved for now. Thanks for your help.

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.