Can't login to Roon on CentOS 8 [Solved - IPv6 Error]

Since about yesterday, I started seeing similar problems than @Uros_Erste with my core on a Centos 8 machine. This setup had been working without problems for more than a year. I have a lifetime subscription (verified on my account page).

Before this core, I had the core on a Mac. I tried to switch to this core on Mac and it works without problems (currently listening music from Qobuz using that core).

I have tried several things:

  • restart core and restart the computer hosting the core
  • retried logging into the core several times (resulting in timeout)
  • connect the Centos machine to the same switch as the Mac
  • looked at the logs and found similar problems that @Uros_Erste saw

Hello @Kai_Makisara ,

Have you by any chance verified that the firewall is set up correctly for your CentOS Core?

One of the first things to try was to turn firewall off. It didn’t help. I have firewall rules for Roon and they have worked so far.

I have managed switches and have seen the IGMP problems. This is why I tested the Centos machine connected to the same switch as the Mac.

I have looked at the logs and found one problem. At one point the requests to fiveaccountserver start to time out. Below are selected messages related to communication with fiveaccountserver (identifiers changed to xxxx, yyyy, etc.):

05/12 03:42:05 Trace: [fiveaccountserver] POST
05/12 03:42:05 Trace: [fiveaccountserver] BODY token=xxxx
05/12 03:42:11 Trace: Successful POST response from
05/12 03:48:20 Trace: [fiveaccountserver] POST
05/12 03:48:20 Trace: [fiveaccountserver] BODY token=xxxx&machine=yyyy&name=zzzz&type=Server
05/12 03:48:27 Trace: Successful POST response from
05/12 03:48:27 Trace: [fiveaccountserver] GOT {“status”:“Success”,“licenseid”:“pppp”}
05/12 04:53:20 Trace: [fiveaccountserver] POST
05/12 04:53:20 Trace: [fiveaccountserver] BODY token=xxxx
05/12 04:55:00 Warn: Error in web request NetworkError (The operation has timed out.)
05/12 04:58:20 Trace: [fiveaccountserver] POST
05/12 04:58:20 Trace: [fiveaccountserver] BODY token=xxxx
05/12 05:00:00 Warn: Error in web request NetworkError (The operation has timed out.)

So, the fiveaccountserver stops responding there.

I tried the first Post with curl: it succeeded. Curl first tried ipv6, but fell back to ipv4. If I try
‘curl -6’, no response is received. (I have a Debian VM running on the Mac. I installed Core there and it works. The curl test there also tries ipv6 first and falls back to ipv4.)

If someone has good ideas, they are welcome. But I have ordered another computer to host the core. It will be using a simpler Linux environment. (The Centos machine has been good for hosting Roon Core, in addition to other things. But it is not widely used for this and I don’t want to spend too much time and energy trying to keep Roon Core running there.)

Try disabling ipv6 in centos! Reboot and see if it works… There can be a lot of problems with ipv6 if not configured properly.

1 Like

I disabled ipv6 (no reboot needed) and now it works. Thanks for the suggestion.

What remains as a mystery is why it worked over one year and suddenly stopped working (no changes in my environment). And why the core in the Debian VM still works with ipv6 enabled. Well, I have to start comparing the ipv6 configurations in these systems … but this is not a Roon problem any more :slight_smile:

The mystery is solved. I could not ‘ping6’ any more. I could ping the ipv6 address the ISP had given, but nothing further. After a couple of hours of looking at the router configuration, I got the idea to reboot the router. After this ‘ping6’ worked. The curl test used ipv6 to connect to roonlabs. And Roon core worked again on the Centos machine with ipv6 enabled :grinning:

The lesson, at least for me, is to first try the ping6 test if I find a connection timing out when the site advertises an ipv6 address. Web browsing, email, etc. has worked without problems because those applications have fallen back to ipv4 for some reason even when DNS has returned ipv6 addresses.

1 Like

Well ipv6 and linux can be a bit annoying sometimes. Newer linux systems lately prefer ipv6 and it can be working on older version on ipv4 but when you update it decides to prefer ipv6 and if your setup in router is incorrect you end up here :smile:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.