Can't login to Tidal account on Roon

Core Machine (Operating system/System info/Roon build number)

Roon Nucleus

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

Wired network

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Meridian 218, Lyngdorf MP-60
Description Of Issue

I can login to my Tidal account on the tidal app and website. When I go to login to Tidal on Roon I am prompted that my username or password are bad. I have tried this with known to work usernames and passwords, and tried to change password once just in case. I have quit, deleted and re downloaded Roon. Any idea? Thanks

Hi Blaine,

Try rebooting the Nucleus using the Web User Interface. Then try logging into Tidal.

Cheers, Greg

1 Like

Hi @Blaine_Bulger,

As Greg mentioned, a reboot of the Core machine will often resolve this type of issue. Let us know if that helps!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.