Can't login to TIDAL account

Same problem. Roon won’t log into my tidal account although the account works fine on the tidal app or web app. I get a message that my tidal account name is not recognized. I tried the troubleshooting in this guide to no avail. Help?

Hey @Peter_K,

I moved your post over to a new thread so we can better assist you.

First, may I ask that you please provide a brief description of your current setup using this link as a guide.

Make sure to describe your network configuration/topology, including any networking hardware currently in use, so we can have a clear understanding of how your devices are communicating.

Since this behavior has occurred have you tried power cycling your Core machine? Often times a reboot will resolve the issue.

If that didn’t yield and positive results, please try the following:

  • Close Roon, find your Roon database and delete the tidal_account file (Database > Registry > Core > tidal_account). Once you do this try to login again.