Can't login to Tidal - getting "invalid csrf" token whenever I try to login in

When I try to login into Tidal a pop up screen asking me to use my e-mail address opens up. After I enter my e-mail, it asks me to click on photos to show I’m not a robot. After I do this, and try to continue it always responds with the “invalid csrf token” and doesn’t allow me to continue further. I have no trouble getting into my Tidal account on my computer or phone.
Equipment is Innuos Zenith server running Roon core (latest Innuos software and latest Roon software, connected by USB (Audioquest diamond USB cable) to an Aqua Dac. an Xfinity router is connected to my Zenith via ethernet cable.
Roon is running Quboz without a problem.

You don’t happen to have Pi Hole or something like that in your network?

HI - No, I don’t have Pi anywhere in my system. thanks.

No problem,

I was referencing this thread:

Hi @Jerome_Dowis

Does the same issue happen if you use a different remote or web browser?

Yes, it happens when I use a different iPad.

Thanks for confirming, @Jerome_Dowis

Do you have a Windows or Mac machine that you could temporarily use as your Core, as a test? Based on the error you’re seeing it sounds like the there is an issue connecting to TIDAL’s server on their login page, but understanding if this is specific to your one Core or if it is happening for all devices would be helpful in pointing us in the right direction.


Sorry, no I don’t have another machine that I could use as the core. thanks.


Hi @Jerome_Dowis

I think the next step here is to enable some diagnostics on your account so our technical staff can get some more insight into what’s going on here.

However, before I enable this feature, I’d like to ask for your help ensuring we gather the right information.

First, can you please reproduce the issue once more and note the time at which the error occurs. Then respond here with that time, and I’ll make sure we review the diagnostics related to that timestamp.

Hi. I just tried it again and got the invalid csrf token again when I tried to login. Time is 5:30 EST (currently on daylight savings time)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.