Can't login to TIDAL with Roon

I’ve similar problem of logging into Tidal from Roon. Every time I tried to login Tidal, Roon direct me to a new Tidal web page and login form there. After I logged in Tidal. The web page could not redirect me back to Roon. I have to go to Roon manually and found that the Tidal which I just logged in was the Tidal’s website, not Roon. I’ve tried using Roon’s Apps for iPad and Mac notebook with same result. All other functions of the Roon are OK, except cannot login to Tidal.
My Roon Server is running on a NUC i5, a Synology NAS with a Linn Selekt and all networked to an Orbi router connect to internet.

Hi @Hong_Tai_Leung,

Welcome to the forum!
Can you confirm that you’re using the latest version of the Roon Remote app to control your NUC?
If you navigate to Roon Settings -> About, can you check to see that Roon build 528 is listed? If you are by any chance using an older version, please upgrade your controllers.

Hi Noris,

I’ve checked my Roon version is 1.7 (build 528) and the RoonOS version 1.0 (build186)

Hi @Hong_Tai_Leung,

Thanks for confirming that you have the newest build of Roon, can you please confirm this next?

1 Like

Cannot find any red warning triangle in the top right hand corner. The screen captures are in sequence. After logged in from the Tidal web page and back to Roon without login.

Hi @Hong_Tai_Leung,

Thanks for the screenshots. Could you please try reinstalling the Roon app on your iPad from the App Store to see if that helps?

Hi Noris,
I’ve already reinstalled the Roon App on my iPad. I’ve also downloaded the Roon App on my MacBook with the same situation, could not login to Tidal.

Hi @Hong_Tai_Leung,

Let’s please keep this discussion in your own thread (linked here: Can't login to TIDAL with Roon).
Can you confirm the following details?

  1. Where is your current country of residence?

  2. What country was your TIDAL account created in?

  3. What is your network setup like? Please list the model/manufacturer of your router and any additional networking equipment.

  4. Are you using custom DNS servers or are you using the ISP-provided ones?

  5. If you try hosting the Roon Core on the MacBook, are you able to login properly with TIDAL? You can host the Roon Core there by:

  • Going to Roon Settings -> General -> Disconnect
  • On the “Choose your Core” screen press “Use this PC”
  • If asked to Unauthorize, select Yes. You can switch Core as often as you’d like but you are limited to one active Core at a time
  • Verify if the same behavior occurs with the Macbook Core

Hi Noris,
1, I’m a Hong Kong residence.
2, My Tidal account was created in Hong Kong.
3. Internet cable from ISP to Orbi RBR50 -> NUC Roon Core
4, Using ISP’s DNS
5, Set up Roon Core on my MacBook Air according to your instructions and everything works, including Tidal. Tried play a few songs from Tidal with no problem.
6, Discounted the MacBook Core and reconnect to the NUC Roon core, same problem (cannot got in to Tidal) occurs with the NUC core.

A post was split to a new topic: Roon + ROCK - Often not logged into TIDAL

Thanks for your help.
Since I’ve found that my MacBook Air’s Roon works OK. I understand that the problem was not from the network. I’ve just reinstalled Roon Core on my NUC and it’s looks like everything works now. I’ve not upgrade to the latest version of Roon yet. But at least I can login Tidal without any problem.

1 Like

Hi @Hong_Tai_Leung,

Thanks for the update here and glad to hear you were able to reinstall the Core on the NUC to resolve this issue!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.