Can't login to Tidal??

anyone else experiencing issues with Tidal? It was fine yesterday, just tried now and I’ve been logged out.

Trying to log back in just comes up with the red “TIDAL login failed” box.

No changes to Roon or Tidal set up, error occurs on Roon desktop AND mobile. Latest version installed across ROCK and PC.

Same - can use the native Tidal app on other devices fine. Logged out and back in again on Roon (the Tidal/Roon login connection seems to work OK) and it never connects within the application, get the same red error box - tried on Android and Windows desktop

ok, so the combination that seemed to sort it is, remove Tidal account from Roon, restart ROCK, log into Tidal on a local browser, add Tidal back into Roon (whilst still signed in on a local browser).


Same. Unable to log in…

Need to cook dinner and then try and sort it out :sweat_smile:

PS: @Simon_Burns Your suggestion did the trick for me. Cheers matey :beers:

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.