Can't play audio to Private zones (only in windows 10)

Hopefully I’ve worded this correctly… I have brainstormed this for awhile with no result.

I have Roon Server running on an OS X box (10.10.5). All audio is stored locally on that box. I have successfully connected to an apple tv in the living room via the ipad as a remote.

I cannot get roon running on may windows 10 computer as a remote to play via Private zone (All/any private zones won’t play). I can get it to play to the apple tv from here though.

  • I have an Adcom GCD700 connect via optical to the windows 10 machine.

  • I have setup the Output settings in Roon to use Optical out, exclusive mode, event driven mode, max volume and limit to 48kHz. (I have tried with event driven on and off.)

  • I made sure that the optical out is allowing apps to take excusive control and given priority.

  • Roon app is allowed access to tcp and udp ports (all just to be safe, also tried with firewall off)

  • I have also tried creating a new user and trying from there, thinking maybe something was weird in my daily user config.

When I click play with event driven mode off:

  • the play button shows the pause symbol (so it’s trying to play)
  • a little blue moving graphic appears next to the song that is playing
  • a green light is next to song and artist on the bottom
  • the song graph is shown on the bottom but stays a 0:00
  • if I click anywhere in the song the line moves to that point and stays
  • if I click play album, it just stays at 0:00 on the first track

When I switch to event driven mode on:

  • I click play, it flashes the song across the bottom for a second then stops. end result is the roon logo across the bottom and nothing is happening.
  • If I click play album, It very quickly (like 2 seconds quick) goes through the entire album and stops. end result is roon logo at the bottom.

Just a sidenote, which leads me to believe it’s something with windows 10 and my roon config…

This is a PC, I have another hard drive that I have Mac OS X installed on that I can boot into running 10.10.5. I have done all steps above within OS X on this machine and it works. Green light when playing without Event Driven Mode. the bitperfect light when playing with Event Driven Mode.

I have tried one other thing, just to be sure audio is working correctly. I have a kodi setup in windows 10 and I turned on airplay support. I can connect the roon server to kodi on the windows 10 machine via airplay and it works. kodi sends the audio to my DAC via optical out. not bit perfect due to airplay limitations.

Any ideas?

Which firewall did you turn off? The Windows firewall on the remote, the OSX firewall with your Core, or both?

Windows and OSX.

Just another thing to add… I tried plugging in headphones to the front speaker jack and using that as an output. Signal Chain shows green light but song playback is just stopped. Seems to be affecting all Private Zones on this machine, digital and analog.

Hmm, ok. Does media playback work in other applications on the Windows PC?

I’m wondering if maybe you’re running a version of Windows that’s missing media components, like Windows N or K, or KN.

Not sure on the version. It was an upgrade to windows 10 home from wondows 7 home edition.

Yes. Media works on other apps. Using Kodi 15.2 I can get access to all audio outs. Wasapi works in Kodi as well.

it is Windows 10 Pro

if it is an error, wouldn’t it be logged somewhere?

Hey @ffk – I just sent you some instructions via PM for uploading some logs to us. We’ll take a look once you’ve sent them and we’ll figure out what’s going on here.

Sorry for the trouble!

So I’ve been brainstorming a bit over the last few days. I’m not even going to try messing with Event Driven Mode. Not sure it’ll work in my current config now.

  • I have the Optical output set to Exclusive Mode, Max Volume, Limit 48kHz.

1 - When I click play, nothing.
2 - If I have radio on and click next track, nothing. It just shows the next track and no sound and time is displayed 0:00,… But, if I keep clicking the next track button the DAC will occasionally change sampling rate modes. So roon is connecting with the DAC but the file is not playing.

I have gotten it to work. I disabled the Realtek High Definition Audio Driver. In the startup items.

Could someone possibly shed some light on how this driver is conflicting? why why why?
(for what it’s worth, everything is working ok with it disabled)