Can't play HiRes file on my network (Audio file loading slowly) [Solved]

I’m experiencing this problem:
Starting form the update to Roon 1.2 I can play files whose resolution is higher than 44.1/16 only on my AURALIC ARIES/VEGA. If I send a DSD or 96 (or higher) file to my two other endpoints (Macintosh based), what I get is few seconds of music with many drops and then this message:

Here’s my setup:
Roon server: Intel DN2800MT Marshalltown Mini-ITX, OS Windows 8.1 32 bit, 128 GB SSD
endpoint 1: AURALIC ARIES (RoonReady) and VEGA;
endpoint 2: Mac mini (end 2009) 2,53 GHz Intel Core 2 Duo, 8 GB 1067 MHz DDR3 and Playback design MPS-3 DAC via USB, OS Yosemite 10.10.5;
endpoint 3: iMac 27” (end 2013) 3,4 GHz Intel Core i5, 16 GB DDR3 a 1600 MHz and M2Tech hiFace DAC via USB; OS El Capitan10.11.4

All tracks are stored on a NAS (Qnap TS-219P II (2 Tb)), shared via smb.
Lan is wired ethernet Cat 6, and switches are HP PS1810-8G and Apple Airport Extreme.

Some observations:
• before Roon 1.2 everything worked flawlessly on all the endpoints, no matter what was the file’s resolution or format;
• assuming that there could be some issues related to the extension (length) of the network that actually covers an entire building of four floors, I moved the server, NAS and all the endpoints to the same switch. Unfortunately the problem persists;
• As for the NAS sharing the same network configuration works flawlessly with other players (i.e. Audirvana, JRiver) which doesn’t use a client/server scheme.

Any suggestion?

Best regards,

Hi @Giulio_Salvioni – sorry for the trouble here.

Can you take one of the high res files you’re having issues with and make a copy on the Core machine’s local drive? Then take the folder where the file is stored locally and add it as a watched folder, and finally try to play to some of the zones you’re having this issue with?

We should absolutely be able to work this out, but it would be helpful to know if things are better playing local files, then we can move forward with that information.


I have the same problem, but I just installed Roon on my main Mac, then on a Raspberry Pi running Ubuntu Mate 16.04 (Node only) and the full version on another Mac, both of which are connected to the main Mac’s Roon. I get the same error trying to send to either machine over a gigabit network using locally stored files.

Edit: Found the problem, though it shouldn’t have caused any issues. I tried reversing the set-up and found my second Mac worked find as the Core and the Main Mac as a remote. After reading around a few more threads with similar issues, I tried creating a new network profile in the System Preferences. That fixed it. Previously I had been using a static IP for the machine, though it shouldn’t have affected anything.

Hi Mike,
thanks for your answer.
The problem persists after having copied the files on the core’s machine local drive.
I assume that it’s not a network issue, am I right?

The first thing I would look at other than Network is you Core machine. Intel Atom might be not powerful enough to work with your current library (how big is it?) or something else might be running simultaneously with Roon which consumes a lot of processing power. Possible ways to troubleshoot this issue (from the easiest one to more difficult):

  1. Disable antivirus software on the Core ( real-time file watching), make sure that nothing else is running on this machine. Try to reproduce this issue with Roon again
  2. Switch your Core to iMac and see if this fix your issue ( This KB article explains how to do that )
  3. Try to install lightweight Linux distro instead of Windows on your Core machine

My library is 2100 albums. On the Core machine the antivirus is already turned off and nothing else is running. The average CPU load, during playback is about 40% with peak at 75%.
I’ll try step 2 asap.

Hi again,
could you please suggest me a Linux distro?

Hey @Giulio_Salvioni,

You can try Lubuntu or Arch Linux. Did you succeed in transferring DB to your iMac, what was the result?


I’m still doing the job.
I’ll be back to you later.

I have one doubt: on my Atom core machine I have two folders RoonServer and RAATServer (and no Roon folder as per the KB article). Do I have to move both folders to my iMac and the reinstall a fresh copy of Roon?

Only RoonServer :slight_smile: Don’t forget to make a backup first!

Do I have to trash the old Roon Folder on the iMac?

You can delete it or rename. Same applies to RAATServer folder on iMac.
Also, when the procedure will be finished make sure that RoonServer on your Atom machine isn’t running.

Ok, let’s try it.

Something went wrong. The new installed Roon is importing everything again :disappointed:
Not a big problem as I don’t use playlists… but a I have to wait until the process will be finished.

Hi, the migration of the Core is almost finished (still importing files) but I can say that the issue is gone and there are no drops with hi res files.

Hi vova,
I’m sorry but the problem is only “moved”. On the iMac, where the Roon server is running (now the core machine), I can play whatever I want at whatever resolution. On the Auralic Aries and on the Mac mini I’m still having the same drops that I had experienced when the core machine was the Atom mini ITX.
Sorry to bother you again…

Hey @Giulio_Salvioni,

OK, that’s is something, now we can exclude Intel Atom from the list. Can you describe in details your network setup, how everything connected to each other? Do you use any additional network features like: port aggregations, power saving modes on your switches, any security measures ?

You didn’t change your network setup during the iMac test, right ?

  1. Switch your Core to iMac and see if this fix your issue

As per my first message all tracks are stored on a NAS (Qnap TS-219P II (2 Tb)), shared via smb.
The lan is entirely wired ethernet Cat 6, and switches are (2) HP PS1810-8G and (2) Apple Airport Extreme and (1) Apple Time Capsule second generation. All the devices are on the same LAN behind a Firewall (Sonicwall TZ 300) who’s acting also as DHCP sever. None of the features you have mentioned is enabled on the firewall nor on the switches. Link to the internet is provided by a modem (1 Gb optical fiber) connected to the Wan port of the Sonicwall which is connected to one HP switch. From this main switch I have:

  1. connection to the Airport Extreme -> Auralic ARIES;

  2. connection to a second HP switch -> Mac mini -> Playback Design DAC (via USB)

From the second HP switch I have:

  1. connection to the Airport Extreme-> iMac 27 -> M2Tech hiFace DAC via USB.

Obviously I didn’t change my network setup during the iMac test.

If you need it I can make a drawing of the network later this evening and send it to you.

Thank you,

I had a similar issue a while ago. In my case “Jumbo packets” were activated on the NAS and caused exactly the issue described here.

1 Like