Can't Play iTunes Tracks Anymore[Solved]

When I first installed Roon a few months ago, I could play music from my iTunes folder.

But now the tracks will no longer play.

FWIW, my iTunes folder is on a NAS. However, FLAC tracks from the same NAS play just fine.

Hello @David_Dennis,

What is happening when you are trying to playback music from your iTunes folder in Roon: do you see an error message or app just skips the track?

Basing on you description, I can assume that your iTunes folder is located in non-standard place, would you mind to read this FAQ topic and confirm that:

  • In iTunes, Share iTunes Library XML option is checked off
  • The iTunes Library.xml file updates when you make changes in iTunes
  • You’ve created a Symlink to your real iTunes Library.xml file


I see neither an error message, nor does it skip the track.

The timestamp stays at 0:00 and nothing every plays.

Hey @David_Dennis,

Can you please describe your setup in details using this FAQ section?

Roon Version: 1.1 (build 102) stable (64 bit)
OS: OSX 10.11.13
Computer: Mac Mini, 2.3 GHz Intel i7, 16 GB RAM
Music Storage: LaCie NAS, with two folder locations:
FLACs: smb://NAS/vol1/Downloads
iTunes: iTunes Music Library, located at smb://NAS/vol1/iTunes/iTunes Music


When I first bought Roon a few months ago, playing from iTunes library worked fine. Now it songs won’t play, despite nothing changing in terms of the location of the iTunes library.

Symptom: all iTunes song appear within the Roon library. But if I try to play one, nothing happens. I can do the following:

  1. Play Now
  2. Roon says ‘Playing 1 Track’
  3. Nothing happens. If I click on the queue it says ‘Nothing Playing’

By the way, at least on my system, the following resolved the problem:

  1. Create the symlink pointing to the NAS in my local iTunes

  2. In iTunes, Share iTunes Library XML option is checked ON

I don’t know if that’s an error in the documentation, but my machine it works the exact opposite of what the FAQ says.

(FWIW, the screenshot in the iTunes FAQ shows the screenshot checked on…)

Hey @David_Dennis,

Glad you were able to sort this out . ‘Checked off’ and ‘checked on’ mean the same thing, but you are right it is a bit confusing - we’ll edit the FAQ.


This topic was automatically closed after 24 hours. New replies are no longer allowed.