Can't Play MQA for More than 5 Seconds

@support I broke the cardinal rule of both audiophilia and tech, and change far too many variables at once, and now I’m trying to sort out where the issue might be.

The problem, as stated in the post title: I can’t seem to get my system to play more than 5 seconds of an MQA track from Tidal before getting a "An audio file is loading slowly. This may indicate a hardware or performance problem” and the library advances to the next track. Some nights this is consistent. Some nights I can play an entire album while penning a support post to the Roon discussion forum without the issue occurring once.

This wasn’t an issue previous to these changes:

  • I moved my Core to the basement, where previously it was in the loft overlooking the Living Room where the stereo in question resides. (Basically, I added walls between the Core and the Bridge)

  • I added a Hifiberry optical output to the Bridge on a Pi 3 (connected wirelessly to the core). There was never a problem when it was plugged directly into a Dragonfly USB Dac. Maybe having the Pi play double duty as a DAC and a Bridge is pushing the limits.

  • I Updated Roon to version 1.5 (Build 334) from whatever the previous version was (the behaviour seems to coincide, but again, I changed other things too.

The System:

Wifi is Google WIFI Mesh network, with three nodes scattered around the house providing what seems to be great reception everywhere.

Roon Core is an old Macbook from 2009 with a 2.0 GHz Core 2 processor, and 8 GB of RAM.

Roon Bridge is the latest Pi 3, running the latest Diet Pi.

The Options:

  • The wifi in the Pi is underpowered and needs to be hardwired via PLC adapters, or via a switch into the closest Google WIFI node that already hosts the internet connection for the Devialet Dialog in its only wired port.

  • The core is too far away, and I need to find a home for it where the spinning up of the Drobo won’t drive me crazy, closer to the audio system than the basement.

  • The core is underpowered for what MQA is demanding, and it’s time to upgrade that computer to a separate NUC running ROCK

  • Blame Devialet

  • Something else I’m not thinking of.

I know that the first few options here are just trial and error options, and I should stop wasting time writing this post and try moving my core, or investing in a few powerline adapters, but I thought I would post here to see if any of you fine folks have suggestions I’m not thinking of.

Hello @vaguedetails,

It does indeed seem like you changed quite a bit of variables all at once. Let’s try to take it one step at a time and eliminate variables one by one from the equation.

  • Starting off with the Macbook, can you confirm that you have disabled the Mac Firewall after the update to v1.5? You can use the instructions listed here to double check that Roon is allowed in communications, we’ve noticed that for some reason this new build does not follow the old firewall rules and adding it manually solved previous issues for users.

  • After confirming the above I would take it one step at a time and Connect the Core directly to your Router or an Unmanged switch, does the issue still occur?

  • Then connect the Diet Pi to the Router or an Unamanged switch, does the issue still occur?

  • I would then double check your Router settings and make sure that you’re following our Networking Best Practices guide, a few things I want to mention off the top of my head is IGMP proxying and double-checking any Multicast settings available on the setup

  • How stable is your internet connection? Can you confirm if it is not due to the internet itself dropping out? Are you able to constantly ping the Diet Pi from the Core? You can use the Mac Network Utility to try pinging the Diet Pi, if the ping fails or isn’t successful, then there is a communication issue between the Core and the Pi.

  • I would also double check that the Diet Pi is on the newest firmware if all of the above fail, maybe there was an underlying issue that got fixed on their end.

  • We would not recommend Powerline adapters in a setup because we’ve seen issues multiple times with them, an Ethernet Cable into an Unmanaged switch would be a much better alternative

Hopefully one of my above suggestions yields the resolution to this issue, but if you’ve tried the above and still no luck, let me know your findings from the tests and we can continue from there.


1 Like

It’s been my experience that these complaints about Tidal are almost always a WiFI problem.

This afternoon, I took my SMS-200 off Ethernet and onto WiFi and those messages started to pop up.

1 Like

Thanks for the extensive reply @noris. That gives me some direction to begin triaging. Cheers.

1 Like

Good to know @xxx. Thanks for the input. Time to experiment.

Whenever I get that message there is a problem with the wifi. I use my phone as an end point in the garage and I know part of my mesh has dropped and I need a wifi reboot.
I would concentrate on the internal connectivity first.

1 Like