Can't play music on iPad as endpoint

Core Machine (Operating system/System info/Roon build number)

Apple Mac mini i3 (2018) 8GB RAM

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ISP modem to Eero hub then ethernet to Netgear switch. Ethernet to Mac mini. Ethernet to Naim Uniti Atom. Wifi over Eero Mesh system 500Gbps average speed.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Naim uniti atom connected via ethernet
Apple iPad Pro 12.9" (2019) via wifi
Audioquest Dragonfly Cobalt DAC/Amp
Focal Clear headphones

Description Of Issue
Hi, I am trying to use my iPad as a Roon endpoint to listen to music through Focal Clears. Whether I plug them in via my Dragonfly Cobalt or just try to play Tidal through the iPad speakers, I get the Tidal streaming error message. This error message is also happening with my music library. Even when using the iPad as an endpoint without headphones. My home network is fast - over 500Mbps over Eero. Any suggestions?

If you unplug the atom and run it wirelessly does the same symptom occur?

Hello @ethelthefrog,

Can you please double check that both Roon and RAATServer have been added as exceptions to your Mac firewall? You can use these instructions from Apple to add them there.

Additionally, does the same behavior occur if you use the Core itself to output to “System Output”? Even if there is nothing connected to this output, it would give us a good data point.

Thanks for the suggestions. The firewall is turned off and the Mac is just running Roon Server. It plays through the system output from iTunes and Tidal.

It works fine wirelessly with the uniti atom

Hi @ethelthefrog,

Can you please try “System Output” via the Roon App and let me know if it works as expected? I understand that it works through iTunes and TIDAL but trying System Output via Roon would give us a good data point.

I would also try temporarily bypassing the network switch and have the Core connected to the router as a test to see if the switch is impacting this issue.

Tried both but no change. I probably should have mentioned I am running iPadOS Beta on the iPad.

Hi @ethelthefrog,

Just to confirm, “System Output” does not work as expected either? This would be the system output of the Core machine when using Roon, and wouldn’t have anything to do with the iPad. I would like to verify this first.

Yes, it works fine. I set up the System Output on the Mac mini from Roon on my iPad and played Tidal through the tiny Mac mini speaker. No issues there at all. BTW, streaming is also sluggish on my iPhone running the latest iOS 13 beta.

Hi @ethelthefrog,

Thanks for confirming that System Output works as expected. Next, I’d like to gather some diagnostics of when this issue occurs. Can I please ask you to reproduce this behavior once more and note the exact local time + date in your country when you notice this issue on your iPad? E.g. 12:35Pm on 9/3/19? Once I have this information I can enable diagnostics and take a look to see if there are any additional clues present. Thanks!

This just occurred at 7:16pm on 9/3/19


Hi @ethelthefrog,

Thanks for letting me know that timestamp, I have gone ahead and enabled diagnostics mode for your account and what this action will do is next time your Core/iPad is active, a set of logs will automatically be generated and uploaded to our servers for analysis.

I can confirm that your Core logs have reached out servers, but the iPad logs have not yet. Can I please ask you to open the Roon app on your iPad when you have a chance and let me know afterwards so I can re-check our diagnostics servers? Thanks!

Ok it’s open

Hi @ethelthefrog,

I can confirm that the logs have reached out servers and have been attached to your case. I will be sure to reach out to you again once these have been reviewed, thanks!

Hi @ethelthefrog,

I spoke to the technical team regarding your case today. They have let me know that they are unable to reproduce your findings with the iPhone they have in-house running iOS 13 Beta.

Since we do not have the new-gen iPad it is possible that this issue is endpoint specific, but we have not seen any other reports regarding this behavior which leads me to believe that this may be due to another factor.

I am next wondering, is the behavior the same if you try a full reboot of your Core, iPad and all your networking gear?

Ok. I probably won’t be able to get to it until Friday but will let you know when I’ve done it. Thanks for your attention to this. I really appreciate it

1 Like

Good news! The resetting worked! Thank you for all your help!


1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.