Can't run on OSX

Eric - I’m facing corrupt file issues too:

I have 4 machines, one is the roon server and the other 3 are running roon control. 3 of the 4 all updated automatically today no issues. The 4th failed on upgrade and I was presented a dialog box from Roon suggesting I go to the website and redownload.

I’ve tried several times and always get the same message from OSX - damaged application. I’ve totally removed Roon from the machine and retried, same error. Otherwise Roon is working from all other machines. It’s just this one machine that continues to report a damaged image of the application.

One important fact. On the good machines the Roon application is 96 MB. On the machine that is failing Roon application ends up being 87.1MB. Here is a Finder listing of the DMG file contents:

Hi @rayski ---- On the 4th machine you mentioned that did not take the update and is facing this issue. What is being ran there, Roon remote?

Moving forward, and this may seem like a silly question, when you removed the the application and tried to re-download did you empty the trash bin first?


I’m running roon remotely on the 3 machines, all pointing to the roon server.

I did not empty the trash bin but can confirm the Application directory no longer had the image in it. I’m not sure what emptying the trash bin would do as the image is running out of the app folder.

The thing that makes me wonder if there is a problem with the download page is that the app sizes are different from the one that automatically downloaded by roon on upgrade (96MB) and the one I manually downloaded from the Roon download page (87.1MB). The two images obviously are not the same.

I’ll try emptying the trash bin.

I removed all instances of Roon, emptied the trash, re-downloaded the image (still 87.1MB) and received the same corrupt error message.

Certainly may not have anything to do with this, but I have seen the same message when trying to run an app downloaded from a developer who is not a registered Apple developer. Going into System Preferences > Security & Privacy under the ‘General’ tab, there are selections for ‘Allow apps downloaded from…’ Checking ‘anywhere’ allowed the app to open. I’ve never seen this with Roon, I would imagine they are registered as developers with Apple…Good luck!

  • Kevin


Yes OSX recognized Roon as not an iStore,iTunes loaded application and halted me. But you can get around that by starting the app while holding down the shift key and forever more it lets you run it. In this case I needed to do that to attempt to run it. But once it did it came up with the corrupt image error.

I really believe the key clue here is that when Roon downloaded the update automatically it loaded a 96MB image, but once I was forced to manually load it from the Roon download page I received a 87MB image. My guess is roon is downloading a different image (the correct one) while the image sitting on the download page is corrupt.

Hi @rayski,

I downloaded the latest version from Roon’s website and got the 87.1 MB size as well, but mine opened fine.

What version OS are you running on the various machines?

Cheers, Greg

All four machines are running OSX El Capitan, version 10.11.6. All 4 are kept up to date with latest OSX drops.

Greg do you have any machines that automatically updated via Roon? Because those for me have the 96MB size. One correction is that the Roon Server application size is 89MB. The roon satellite machines are 96MB except for the one that won’t run.

I’m not sure if it’s MacOS dependent or not, but I’m running Sierra 10.12.

Whether automatic or manual, the Roon file sizes are 87.1 MB for me.

Cheers, Greg

I’m stumped. Not sure why my Roon auto loaded files are different size than yours. Does roon load a different file for Sierra than El Capitan? Need Roon Developers to answer that one.

I actually have held back on upgrading my Macs to Sierra only because of the reported troubles in these forums with Roon and Sierra. So I’ve been waiting.

I’m fairly certain that the version up on the Roon downloads page right now is Build 161 (87.1MB). The copy I downloaded this morning turns out to have been 161 and I just tried again a couple of minutes ago and it was also 161.

Trash the Application and try nuking your ~/Library/Roon folder as well. If you’re only using this machine as a remote then you won’t really lose anything by doing that.

You can also grab a copy of AppCleaner and it will find everything associated with Roon and clear it out.

Of course, if you haven’t already it’s worth rebooting that machine as well.

I just auto-upated from within the Roon app on OSX 10.11.6 running on an old 2011 macbook Pro. The size of the file is 96.0 MB. Roon is now running build 165 with no issues.

[edit] Note that this is roon core, not roon server.

We’re looking into this @rayski.

We have a few theories, but you may be able to go into System Preferences > Security & Privacy > General. Then, unlock in lower left to make changes and select Allow apps downloaded from Anywhere.

Let me know how it goes, and I’ll follow up when we have some more information.

what is the name of the app bundle you guys are running? or ?

Mike that (system preferences>security…) did the trick. But it bugs the heck out of me why. I used the Apple workaround of loading non-iTunes/AppStore loaded apps like always do and did initially with Roon but this time it doesn’t work. Then by allowing it to download and load apps from anywhere, in theory, I’ve should have saved myself the one step of opening it with the shift key the first time. But it worked.

Oh and also the now resolved machine has a 87.1MB image while the other non-core machines have 96MB image. But yet they’re all v1.2 Build 165.

I’m happy but still very curious. But thank you just the same.

To Danny - on all 3 satellites and on the core machine.