Can't run Roon on my Synology


Before buying a dedicated Roon Server, I decided to try and install it on my Synology DS718+ first.

I followed the instructions on the Rieke blog and downloaded the .spk from the link.
After installing the Roon app (which went well) it states that the application is Stopped when looking in my Package Center. When I click Run, it does something (Loading), but still, do not start.

Anyone that can help me where to troubleshoot?
To be honest, I’m not a Linux guru, so please describe in details if I need to access a Terminal or something alike - thank you.

That is absolutely not true. The Celeron 3455 does just fine as a Roon Core.
Upsampling to DSD128 without any issues.

Hi Lars,
I assume, you have created a shared folder “RoonServer” before you’ve installed the app.
On which volume is the shared folder set up (Internal/external)?

Hi, thank you for responding to me :slight_smile:
I believe the Intel processor along with 6Gb Ram and 7200rpm harddrives should be enough to run Roon - of course the question is how well, but at least it should not be a problem launching it.

I have made a shared folder called “RoonServer” as described by you Crieke on “Volume 1”.
My music libraries is also located on the same volume, but since I cannot Run the server, then it should not be an issues about this.

Any good suggestions?

Absolutely correct John, but it should still be possible to try before investing +1500 USD on a Roon server or similar :slight_smile:

On the Synology, there’s an app (package) called “Log Center”. You might open that up and see if there are any messages which would give you an idea about what is going on.

Thanks Bill. I went in but the last log regarding Roon says “Package Roon Server has successfully been repaired”.
After when I have clicked “Run” no logging is being made.

While I appreciate your concerns, your points made here are nowhere near relevant, helpful or even remotely true.

Found my problem.
Rieke, you were asking the correct question.
I went back and removed everything and started all over and now it works.

Reason: I had originally named the shared folder “Roon Server” after the installation (because it did not work) I changed the name to “RoonServer”, but it was already too late apparently.

Many thanks for your help - have a great day/evening :slight_smile:


Absolutely not. But you obviously have no experience with either Volkswagens or Celeron J3455 processors so your statements are simply false and misleading.



Let’s stay focused on the OT and not start an ideology war here.

It is not true, that it won’t run on a Celeron CPU, even though the it might not be within the recommended specs. But it is clearly able to run Roon Server. (the specs for supported platforms is just a 64-bit intel platform, as stated here.

If the performance of the core is sufficient, has to be evaluated by the individual user. Every use case for Roon Server might be different and not every use case might need the cpu horsepower. Blaming everything on the performance here, is not focused on the original issue and might even scare away new users.


I could not agree more with you Christopher.

After doing some tests I can say that everything is running perfectly so far with no “hiccups” at all.
I have not tried DSD yet but high res audio with 192 kHz and 24 bit works like a charm.
So my Volkswagen is doing great… for now anyway :slight_smile:

Thanks very much, everyone.