Can't save songs to library

Core Machine (Operating system/System info/Roon build number)

Intel NUC5PGYH running ROCK Version 1.6 build 416. System has been running for many months with no issues. Library is on a USB drive connected directly to the NUC.

Network Details (Including networking gear model/manufacturer and if on WiFi/Ethernet)

ROCK is connected to other components by Ethernet, but problem exists when using ROCK directly too.

Audio Devices (Specify what device you’re using and its connection type - USB/HDMI/etc.)

Numerous Roon End Points in home - all functioning normally, but none will add songs to library.

When the “+ Add Album to Library” Link shows up for a song not currently in my library, if I click on the link, I see the progress “circle” running for some time. It will disappear after a few seconds, but the link is still there, and the Album is not added to my library. Songs can be added to playlists with no issue.


I discovered that the same thing happens from an album with the large “Add to Library Button”. However, I get a message that it is taking longer than normal to add the album, and that Roon will keep trying in the background. There is also a spinning progress bar in the upper right. When clicked on, it tells me that I am adding musing to library, but nothing is being added or identified. In settings, storage correctly identifies my backup drive. I have tried to disconnect and reconnect the drive, and it detects correctly. there is a large amount of space available (several TB)

Hi @Derrick_Stasiuk,

Just to verify, has this always occurred for you, or did this just recently start happening?

Are you using TIDAL, Qobuz, or both?

Just using TIDAL. Library has worked with no issues ever since Roon was originally installed. Problem only recentlg exhibited itself…

Hi @Derrick_Stasiuk,

Since experiencing this issue have you tried rebooting your Core machine?

Was there any change to your networking setup around this time?

Have you tried logging out of TIDAL in Roon and logging back in?

Core had been rebooted, and no changes to network settings… However, logging out of Tidal from within Roon and logging back in cured my issue. Thanks for your help!

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.