Can't see dCS network bridge on network [Firewall Configuration Issue]

I have the latest version of Roon and now I can’t see my dCS network bridge and/or my Debussy dac on my network. I need some basic guidance on how to troubleshoot this.


Can one assume that it worked with the previous build? Did you try rebooting everything?

Yes, it worked totally fine. And I don’t think it is my network because I can play music using the dCS app via my network bridge and the Debussy. And I have rebooted my computer, router and the audio gear…

What happens if you go into Settings and under the Audio tab? Is the dCS there and not enabled?

No it’s not there at all. And if I go to settings/audio/add a networked device it doesn’t show up either. I am using the dCS gear right now, again using the dCS app. Roon can see my library but will only play on my MacBook Pro

Is it possible that the devices are somehow on different networks or sub nets?

I don’t even know how to set up a sub net - as far as I know there is only a single network in the house. The dCS network bridge is hard wired to my network. Sorry to sound clueless, but how would I check that? Also, I’ve noticed my Roon app on my iPad can’t see the Roon core on my MacBook Pro. Never had that issue before either.

I just looked at my router and everything connected is 192.168.1.x, so I believe that means everything is on the same network - correct?

To me everything you are describing points to stuff being on different networks. You should be able to check the IP address of all the devices on your networks to confirm this. The dCS network bridge must have a graphical interface that would allow you to check it? There is a network program called Fing that allows you to see all on your network. This would help you confirm that everything is on the same net.

I can see that everything on my network is connected to a 192.168.1.x address, so I don’t think that is the issue…Do you know how I can completely remove roan and reinstall it? I tried that but there must be some user files somewhere I can’t find, because the reinstall instantly recognized me and my library. Clearly, I am not very network savvy and I was afraid of exactly this type of issue when I got Roon…spending more time troubleshooting than actually listening to music.

Flag @support on this. I feel confident that if I was sitting in your chair I could figure it out but absent that you need help from the professionals.

Have you checked your computer’s firewall (and any anti-virus software) and made sure there are exceptions for RAATServer and Roon?

That is a great suggestion. I seem to remember that when I did the 269 update on my Mac it asked me if I wanted to permit access to Roon. Never asked me this before. Perhaps you missed that step of answered incorrectly?

Thank you for the help. I thought I had flagged @support, but maybe not…

I am pretty sure I messed up the connection to the RAAT, because I was asked that and I declined it, not realizing what it was. I have figured out how to completely uninstall Roon and I am now reinstalling it and hopefully can go to a backup to restore everything I need. But again, thanks and looks like a hard lesson learned for me. Luckily my music library isn’t massive so it shouldn’t take too long…

OK, got it working again. Totally my fault, but I couldn’t figure out how to re-establish a connection to RAAT without completely re-installing. Anyway, thanks again to the board for help and suggestions

1 Like

Hi Eric,
How do you connect with RAAT once Roon has been installed and configured.
I’m having a similar problem with my Bryston BDP-2: it’s on the network but Roon can’t see it.

The short answer is I’m not sure - that’s why I uninstalled Roon and re-installed it. Then I went to a previous backup of my library and everything worked again. I was able to see the dCS on my network. Perhaps someone from Roon can give us all some advice on what to do if we lose access to RAAT. And just a reminder: in order to completely remove Roon from your system you need to go to your Library folder and remove the Roon folder (on a Mac). I found that out from other posts on this board. Probably my approach was crude and a bit of overkill, but it did work.


So it appears I have this issue again with Roon not being able to see my dCS network bridge at all. I had this same exact problem a few days ago. In both cases, I believe it was after a Mac OS software update and restart. The last time I couldn’t figure out how to fix it so I completely re-installed Roon and then it worked again fine.

I don’t think it is a network issue because I can see the dCS on my network and use it via the dCS app. I think I somehow lose access to RAAT, but I am not sure why or how to reconnect it.

Any advice or help for me? I don’t want to reinstall Roon again… and if I try add networked device, Roon doesn’t see the dCS…

I am running Roon 1.3 (build 269) 64 bit on a
MacBook Pro (15 inch, 2017, 16GB RAM) with OS High Sierra 10.13.1
Music library is stored on a QNAP TS-251+

I had the same with my dCS Rossini streamer/DAC.
The issue was/is that the connection broke when the files were changin from a high resolution to a low resolution and visa versa.
I wait now almost 9 months for a solution.
Now I set Roon DSP upsample to DSD64.
So there wil be no changing of resolution.
The update for the dCS Rossini wil be there in October 2017…